IntelliJ 9 M1 Experiences

Hi all,

I see you've implemented the background loading of most aspects of a project, which is (conceptually) great!! However, while I know this version really is an 'in progress' version, it's unusable for me. IntelliJ won't stop eating my CPU. Especially when making changes to Pom's, IntelliJ will go to 100% CPU, and not respond anymore. Making changes to the pom's also has a lot of effect on the project structure: when making any kind of change (for example, the addition of a dependency), and even without saving, IntelliJ removes all the classes from view and starts processing the pom's, causing a high cpu load, which stops IntelliJ from responding. It's almost as if the background tasks (sometimes more than 20...) are running at a higher priority than the UI, which I find hard to believe.

On a small side note: I really don't like the new icon with the project options (scroll to/from source, flatten packages, etc!). The icons were much more intuitive and much easier to work with, since they are always there. Setting my correct settings for the project caused my twice as many clicks, since each click in the new version of intellij causes the project options popup to disappear, and, since the menu only contains text, I have to think more about which options I'm interested it. Thirdly, since the popup is text only, it doesn't have the visual appeal as the previous icons did.

I hope you can do something with my comments, if you need some CPU snapshots, I could try to create some.

Greetings,

Erik Pragt

11 comments
Comment actions Permalink

Hello Erik,

CPU snapshots are always welcome.

As for the project view - how often do you actually change the settings of
the project view? Isn't it a one-time operation?

I see you've implemented the background loading of most aspects of a
project, which is (conceptually) great!! However, while I know this
version really is an 'in progress' version, it's unusable for me.
IntelliJ won't stop eating my CPU. Especially when making changes to
Pom's, IntelliJ will go to 1

00% CPU, and not respond anymore. Making changes to the pom's also has
a lot of effect on the project structure: when making any kind of
change (for example, the addition of a dependency), and even without
saving, IntelliJ removes all the classes from view and starts
processing the pom's, causing a

high cpu load, which stops IntelliJ from responding. It's almost as if
the background tasks (sometimes more than 20...) are running at a
higher priority than the UI, which I find hard to believe.

On a small side note: I really don't like the new icon with the
project options (scroll to/from source, flatten packages, etc!). The
icons were much more intuitive and much easier to work with, since
they are always there. Setting my correct settings for the project
caused my twice as many clicks, s

ince each click in the new version of intellij causes the project
options popup to disappear, and, since the menu only contains text, I
have to think more about which options I'm interested it. Thirdly,
since the popup is text only, it doesn't have the visual appeal as the
previous icons did.

I hope you can do something with my comments, if you need some CPU
snapshots, I could try to create some.

Greetings,

Erik Pragt

---
Original message URL:
http://www.jetbrains.net/devnet/message/5241342#5241342

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Hi Dmitry,

I'll see if I can find some time to enable the CPU snapshot buttons again. And how often do I change the settings? Well, I also though it would be not that often, but I change it almost every time when I create a new package, since normally my packages are flattend, and it's hard to create a package inside a package without typing the whole com.company.project.domain.etc again. Also, sometimes IntelliJ looses focus on the current open file, so clicking on the 'scroll from source' button twice usually fixes this. With the new 'fold out' setting thing, these things have become a little harder..

Greets,

Erik

0
Comment actions Permalink

Hello Erik,

As you can see, both of the use cases you're describing are not actually
use cases of configuring the project view. We'll add a "Scroll from Source"
button in Project View (it'll do what toggling Autoscroll from Source twice
did), and we'll find a better UI for creating packages when "Collapse empty
middle packages" is used.

I'll see if I can find some time to enable the CPU snapshot buttons
again. And how often do I change the settings? Well, I also though it
would be not that often, but I change it almost every time when I
create a new package, since normally my packages are flattend, and
it's hard to create a package
inside a package without typing the whole
com.company.project.domain.etc again. Also, sometimes IntelliJ looses
focus on the current open file, so clicking on the 'scroll from
source' button twice usually fixes this. With the new 'fold out'
setting thing, these things have become a little harder..


--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

I have also experienced a problem with IntelliJ 9M1 and increased CPU usage.  Any time I make any changes to a pom file, especially in a multi-module project, my project dependencies start resolving in the background. The problem with this is when I make any changes to the actual file the resolving dependencies in the background starts and it eats up my CPU blocking me from doing anything else on the system. By a change to the pom file, I mean any declaration, removal, or editing of tags or data contained within a tag will cause the auto-resolving of dependencies in the project. 

I also appreciate the added OSGi support, now if you guys could get some Spring DM Server support that would be much welcomed!

0
Comment actions Permalink

I've been using IntelliJ IDEA 9.0 M1 primarily for Flex development and I notice each time I leave the IDE (i.e. give focus to something else such as my web browser) and then go back to the IDE it's like IntelliJ starts doing some background work (I think it is since I see a small icon in the project tree view spin and then disappear).

Also, the content-assist (at least in the Flex development side) is often slow.  I'll type something and press Ctrl+Space and I typically have to wait several seconds for the options list to populate...basically I usually just type things out b/c it takes to long to wait for content-assist. I am running on a pretty good laptop, specs include:

- Intel Core 2 Extreme CPU @ 2.53ghz
- 4 GB RAM
- 64-bit Vista

I've modified the IntelliJ options so the IDE (idea.exe.vmoptions) to look like:


-Xms32m
-Xmx512m
-XX:MaxPermSize=150m
-ea


Anyone experience these issues, even in non-Flex development?


0
Comment actions Permalink

Please, file JIRA request with CPU snapshots as described in
http://www.jetbrains.net/devnet/docs/DOC-192

craig wrote:

I've been using IntelliJ IDEA 9.0 M1 primarily for Flex development and I notice each time I leave the IDE (i.e. give focus to something else such as my web browser) and then go back to the IDE it's like IntelliJ starts doing some background work (I think it is since I see a small icon in the projec
t tree view spin and then disappear).

Also, the content-assist (at least in the Flex development side) is often slow. I'll type something and press Ctrl+Space and I typically have to wait several seconds for the options list to populate...basically I usually just type things out b/c it takes to long to wait for content-assist. I am run
ning on a pretty good laptop, specs include:

- Intel Core 2 Extreme CPU @ 2.53ghz
- 4 GB RAM
- 64-bit Vista

I've modified the IntelliJ options so the IDE (idea.exe.vmoptions) to look like:


-Xms32m
-Xmx512m
-XX:MaxPermSize=150m
-ea

Anyone experience these issues, even in non-Flex development?



---
Original message URL: http://www.jetbrains.net/devnet/message/5241513#5241513



--
Best regards,
Maxim Mossienko
IntelliJ Labs / JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

0
Comment actions Permalink

Well, this is exactly the same behaviour I have, even though my project is not so big (1 master pom, 8 projects, each project around 5 modules, so around 40 maven projects in total (which will expand to around 80-100 within the next year)

0
Comment actions Permalink

I have the exact same issue in editing poms. I noticed that heap usage was pinned at the max available (128M). I increased this to 512M and it is still pinned at the max available. I suspect the CPU is being consumed doing GC.

btw

Great work on the OSGi support. M1 was released on the exact week I needed an IDE to support OSGi development.

Keep up the good work, just please, please get us an update asap on the performance issues.

Jay

0
Comment actions Permalink

Hi,

Is somebody looking at this problem. I'm using the latest 90.94 release for flex and java development and it is still experiencing this issue. In the beginning everything works fine but after a certain period IntelliJ starts checking files in the background (you can see them passing on the message bar) and this takes about 50% of my modest cpu. From then on it's nearly impossible to continue working in a pleasant way. The IDE doesn't follow anymore,.... very frustrating. Most of the time i end by exiting Intellij and starting it again.
I'm an Intellij fan since version 4 but now i'm really at the point considering to change to Eclipse. Anyway this is not what i call 'develop with pleasure' !
At least there should be a way to disable this background checking process(es).... is this possible ?

grtz,

bratz.

0
Comment actions Permalink

A bug ticket with CPU shapshot should greatly improve the chance for a
quick fix.

See here how to capture such a snapshot:
http://www.jetbrains.net/devnet/docs/DOC-192

-tt

0
Comment actions Permalink

hi Craig,
Don't do flex development, but I've had much better results with the following settings

-Xms128m -Xmx512m -XX:Permsize=128m -XX:MaxPermSize=256m -ea

Regards,
Mark.

0

Please sign in to leave a comment.