Intellij not refreshing the screen properly (Ubuntu 9.04)

Hi,

I am having issues today with IntelliJ not refreshing the screen properly under Ubuntu 9.04 and sun java 1.6.0_16 (Java Hotspot Server VM according to IntelliJ about box).

I tried disabling compiz by running:

metacity --replace

and then restarting IntelliJ, but the result is the same.

It is getting almost to the point where it is impossible to work with because for each line I type I have to use the scrollbar to force the repaint of the edit window.

Any ideas ?

regards,

Wim

Edit: I selected the client JVM by adding -client to the idea.vmoptions file, but that does not help.

12 comments
Comment actions Permalink

I tried with setting IDEA_JDK to an older version (1.6.0_12), because Ubuntu recently updated the java version to 1.6.0_16, but that does not change anything. There must have been some other update which broke things.

0
Comment actions Permalink

Wim,

I am running IntelliJ also under Ubuntu 9.04 with sun java 1.6.0_16.
I don't have any problems except infrequently the JVM crashes.

It sounds like you have a graphics card driver problem.
If I goto System->Administration->Hardware Drivers I have the proprietary NVIDIA accelerated graphics driver (version 180) installed.

One possibility is to trying different graphics drivers. Other possibility is to just buy a new graphics card, preferabbly NVIDIA,
and see if it fixes the problem.  If you aren't doing 3d graphics or running dual-DVI, any cheap graphics card will work.  I have a $40 fanless card made by Sparkle with NVIDIA chip that supportes PCI Express x16 2.0.

I dont' think your problem has anything to do with IntelliJ.  Goto ubuntuforums.org and ask for further help troubleshooting your problem.

-Alex

0
Comment actions Permalink

Hi Alex,

thank you for you reply. I also have nvidea, driver version 180.

The strange thing is that I only have the repaint problem in IntelliJ. I don't have it in Firefox, Nautilus, the terminal, ...

I will try my luck on the ubuntu forums.

regards,

Wim

0
Comment actions Permalink

You didn't say what version of IntelliJ you are using?
I am using the latest EAP Maia 10762 9.x, although I was using the previous release 8.x on this same setup without any problem. Before that I was on windows xp sp2.

I have Compiz turned off (Under System->Preferences->Appearance->Visual Effects, I have "None" selected.

0
Comment actions Permalink

I am using the latest released one (8.1.3). I have compiz enabled, but I tried disabling and the result was the same. I will try with the latest EAP version to see if that helps.

0
Comment actions Permalink

Indeed the latest EAP build does not have this problem! Thanks for the tip, now I can work with pleasure again

0
Comment actions Permalink

Hello

I have the same problem that is described in the first post. Intellij IDEA 8.1.3, Ubuntu 9.04 and sun java 1.6.0_16 and Intellij is not refreshing. On the same machine I tried to install Intellij on a windows xp with java 1.6.0_16 and encountered the same problem.

On both OS the EAP version works without problems.

Any solution for solving this problem except changing to the EAP version of IntelliJ?

Thanks for your answers

Regards,
Daniel

0
Comment actions Permalink

I did not try it in windows, it is good to hear you have it also there, because Linux is probably not a priority for them. I have opened issue http://jetbrains.net/tracker/issue/IDEA-24877 to track this problem. It would be good if you can add your experience there.

regards,

Wim

0
Comment actions Permalink

As I suggested to Wim, I suspect it is a graphics card problem.

One thing I forgot to mention before, is you can turn off some of the java2d and 3d features which rely on graphics card acceleration.
I remember having to do that alot in the past, but in recent years, I haven't run into problems like you're describing.

Checkout this page
http://java.sun.com/j2se/1.5.0/docs/guide/2d/flags.html

Try some options like  -Dsun.java2d.noddraw=true and see if that fixes your problem.

Another thing you can try is the EAP of java 6u18. I have been using it for almost three weeks now, and feel like it is very solid.
On Ubuntu  6u18, I was occasionally getting crashes of IDEA. But with 6u18ea, I haven't gotten a single crash.

http://download.java.net/jdk6/6u18/promoted/b02/binaries/

-Alex

0
Comment actions Permalink

Thanks for your replies

I tried the to set the java parameter but this did not fix the problem. Afterwards I installed the java 1.6.0_18-ea. This fixed the problem. Until now the rendering of intellij works properly.

Thanks again for this tip.

I will update the issue with my experience.

Daniel

0
Comment actions Permalink

Unfortunately the trick with the jvm 1.6.0_18-ae did not work. After a while I got the same refreshing problem. It seems that the only solution is to switch to the EAP version of IntelliJ

0
Comment actions Permalink

The new 8.1.4 release has fixed this for me.

0

Please sign in to leave a comment.