Idea 9 beta + GWT facet autodetection: no GWT module

Hi,

I'm testing the new Idea 9.0 beta. I've imported my Maven projects which contains 3 (Maven) modules, each one with a GWT facet. These facets are correctly autodetected, however in the project settings, no GWT module appears in the "GWT module/Output relative path" list.

I've tried to remove and re-add the facets without success. And it seems that this module list can't be updated by hand. Is there any trick to get around this?

Thanks.

3 comments
Comment actions Permalink

Do you have .gwt.xml files under source roots of your modules?

Hi,

I'm testing the new Idea 9.0 beta. I've imported my Maven projects which contains 3 (Maven) modules, each one with a GWT facet. These facets are correctly autodetected, however in the project settings, no GWT module appears in the "GWT module/Output relative path" list.

I've tried to remove and re-add the facets without success. And it seems that this module list can't be updated by hand. Is there any trick to get around this?

Thanks.

---
Original message URL: http://www.jetbrains.net/devnet/message/5249377#5249377



--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0
Comment actions Permalink

it is very strange: I did the migration of the same project to Idea 9 on another computer and now the GWT facets are correctly configured.

but now, I've got a new and very annoying problem: the GWT modules are not compiled at all! I did several "rebuild project", the rest (the server part) is correctly compiled but it seems that the GWT compiler is never called. And there is no error message.


Boris.

0
Comment actions Permalink

BTW, I've noticed that the checkbox "Run GWT compiler on make" disappeared.

I find it very useful: it allows me to avoid the very long GWT compilation when I work on other modules.

Boris.

0

Please sign in to leave a comment.