Debugging in 1126 still takes ages

Doing any of step over/into/out takes at least 5 seconds (on my 2 GHz machine).
Do others also see this? Is there already a tracker entry?

24 comments
Comment actions Permalink

Here are two things to check. Apologies if they are obvious.

Enable "Suspend All Threads While Stepping" option; it's the bottom right icon in the debugger icon group.

Reduce the number of expanded variables in the Frame tab or the number of watched expressions.

-Dave

0
Comment actions Permalink

Enable "Suspend All Threads While Stepping" option; it's the bottom right

icon in the debugger icon group.

You probably meant DISABLE it, right? "Suspend All Threads While Stepping"
option being enabled is slower (and it's disabled by default).

--
Valentin Kipiatkov
Chief Scientist, Vice President of Product Development
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


"Dave Kriewall" <no_mail@jetbrains.com> wrote in message
news:15297182.1075327936355.JavaMail.itn@is.intellij.net...

Here are two things to check. Apologies if they are obvious.

>

Enable "Suspend All Threads While Stepping" option; it's the bottom right

icon in the debugger icon group.
>

Reduce the number of expanded variables in the Frame tab or the number of

watched expressions.
>

-Dave



0
Comment actions Permalink

Was debugging of the same application under the same conditions faster in
3.0? Please check.

--
Valentin Kipiatkov
Chief Scientist, Vice President of Product Development
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

"Stephen Kelvin" <mail@gremlin.info> wrote in message
news:13563102.1075311193694.JavaMail.itn@is.intellij.net...

Doing any of step over/into/out takes at least 5 seconds (on my 2 GHz

machine).

Do others also see this? Is there already a tracker entry?

>


0
Comment actions Permalink

We (Gentleware) have developers using the very same application with Idea 3.0.5. Stepping into/over is almost instantaneous there.

0
Comment actions Permalink

I have had horrible debugging performance for ages (under linux)
http://www.intellij.net/tracker/idea/viewSCR?publicId=14855

Bug closed as "Problem"!

0
Comment actions Permalink

I've also been experiencing this. Our project is running on WebLogic using JDK1.3.1.

I have found removing the -server option from the java command line helps a lot, but the debugger is still nowhere near as fast as the IDEA 3.0 users here.

0
Comment actions Permalink

I've been seeing it as well. Also with WebLogic 7.0.1.0 and JDK1.3.1.

I've noticed that there is often message text that says something about
evaluating Collection.isEmpty() or Collection.size(). Even after all of the
other variable values are displayed in the Frame tab, any collections take
many seconds to be evaluated. Once all of the variables are evaluated, the
GUI is responsive until it needs to evaluate variables again.
It seems to be much more responsive when there are no Collections or Maps in
the current Frame. (Not a common occurrence when working with a J2EE Web
App.
I could try to avoid the Collections framework, but that would be a
nightmare.

Please, please, please, find a way to speed up the evaluation of Collections
from within the debugger.

Tim

"Ash Searle" <no_mail@jetbrains.com> wrote in message
news:9749386.1075386427477.JavaMail.itn@is.intellij.net...

I've also been experiencing this. Our project is running on WebLogic

using JDK1.3.1.
>

I have found removing the -server option from the java command line helps

a lot, but the debugger is still nowhere near as fast as the IDEA 3.0 users
here.
>


0
Comment actions Permalink

Do you have the alternative view for collections switched on?

N.

Tim Haley wrote:

I've been seeing it as well. Also with WebLogic 7.0.1.0 and JDK1.3.1.

I've noticed that there is often message text that says something about
evaluating Collection.isEmpty() or Collection.size(). Even after all of the
other variable values are displayed in the Frame tab, any collections take
many seconds to be evaluated. Once all of the variables are evaluated, the
GUI is responsive until it needs to evaluate variables again.
It seems to be much more responsive when there are no Collections or Maps in
the current Frame. (Not a common occurrence when working with a J2EE Web
App.
I could try to avoid the Collections framework, but that would be a
nightmare.

Please, please, please, find a way to speed up the evaluation of Collections
from within the debugger.

Tim

"Ash Searle" <no_mail@jetbrains.com> wrote in message
news:9749386.1075386427477.JavaMail.itn@is.intellij.net...

>>I've also been experiencing this. Our project is running on WebLogic


using JDK1.3.1.

>>I have found removing the -server option from the java command line helps


a lot, but the debugger is still nowhere near as fast as the IDEA 3.0 users
here.


0
Comment actions Permalink

I vaguely remember that option from previous builds but I can't find it now.
Where do I (un)set it?

"Nathan Brown" <nedski@yahoo.com> wrote in message
news:bvba6e$bak$2@is.intellij.net...

Do you have the alternative view for collections switched on?

>

N.

>

Tim Haley wrote:

>

I've been seeing it as well. Also with WebLogic 7.0.1.0 and JDK1.3.1.

>

I've noticed that there is often message text that says something about
evaluating Collection.isEmpty() or Collection.size(). Even after all of

the

other variable values are displayed in the Frame tab, any collections

take

many seconds to be evaluated. Once all of the variables are evaluated,

the

GUI is responsive until it needs to evaluate variables again.
It seems to be much more responsive when there are no Collections or

Maps in

the current Frame. (Not a common occurrence when working with a J2EE Web
App.
I could try to avoid the Collections framework, but that would be a
nightmare.

>

Please, please, please, find a way to speed up the evaluation of

Collections

from within the debugger.

>

Tim

>

"Ash Searle" <no_mail@jetbrains.com> wrote in message
news:9749386.1075386427477.JavaMail.itn@is.intellij.net...

>
>>I've also been experiencing this. Our project is running on WebLogic
>

using JDK1.3.1.

>
>>I have found removing the -server option from the java command line

helps

>

a lot, but the debugger is still nowhere near as fast as the IDEA 3.0

users

here.

>
>
>



0
Comment actions Permalink

Never mind, I found it using IDEA Help. Imagine that!

BTW, It was on.
I'll try it after turning it off.

Tim

"Tim Haley" <ymaraner@yahoo.com> wrote in message
news:bvbb7n$km2$1@is.intellij.net...

I vaguely remember that option from previous builds but I can't find it

now.

Where do I (un)set it?

>

"Nathan Brown" <nedski@yahoo.com> wrote in message
news:bvba6e$bak$2@is.intellij.net...

Do you have the alternative view for collections switched on?

>

N.

>

Tim Haley wrote:

>

I've been seeing it as well. Also with WebLogic 7.0.1.0 and JDK1.3.1.

>

I've noticed that there is often message text that says something

about

evaluating Collection.isEmpty() or Collection.size(). Even after all

of

the

other variable values are displayed in the Frame tab, any collections

take

many seconds to be evaluated. Once all of the variables are

evaluated,

the

GUI is responsive until it needs to evaluate variables again.
It seems to be much more responsive when there are no Collections or

Maps in

the current Frame. (Not a common occurrence when working with a J2EE

Web

App.
I could try to avoid the Collections framework, but that would be a
nightmare.

>

Please, please, please, find a way to speed up the evaluation of

Collections

from within the debugger.

>

Tim

>

"Ash Searle" <no_mail@jetbrains.com> wrote in message
news:9749386.1075386427477.JavaMail.itn@is.intellij.net...

>
>>I've also been experiencing this. Our project is running on WebLogic
>

using JDK1.3.1.

>
>>I have found removing the -server option from the java command line

helps

>

a lot, but the debugger is still nowhere near as fast as the IDEA 3.0

users

here.

>
>
>

>
>


0
Comment actions Permalink

That should help a lot.

N.

Tim Haley wrote:

Never mind, I found it using IDEA Help. Imagine that!

BTW, It was on.
I'll try it after turning it off.

Tim

"Tim Haley" <ymaraner@yahoo.com> wrote in message
news:bvbb7n$km2$1@is.intellij.net...

>>I vaguely remember that option from previous builds but I can't find it


now.

>>Where do I (un)set it?
>>
>>"Nathan Brown" <nedski@yahoo.com> wrote in message
>>news:bvba6e$bak$2@is.intellij.net...
>>
>>>Do you have the alternative view for collections switched on?
>>>
>>>N.
>>>
>>>Tim Haley wrote:
>>>
>>>
>>>>I've been seeing it as well. Also with WebLogic 7.0.1.0 and JDK1.3.1.
>>>>
>>>>I've noticed that there is often message text that says something


about

>>>>evaluating Collection.isEmpty() or Collection.size(). Even after all


of

>>the
>>
>>>>other variable values are displayed in the Frame tab, any collections
>>
>>take
>>
>>>>many seconds to be evaluated. Once all of the variables are


evaluated,

>>the
>>
>>>>GUI is responsive until it needs to evaluate variables again.
>>>>It seems to be much more responsive when there are no Collections or
>>
>>Maps in
>>
>>>>the current Frame. (Not a common occurrence when working with a J2EE


Web

>>>>App.
>>>>I could try to avoid the Collections framework, but that would be a
>>>>nightmare.
>>>>
>>>>Please, please, please, find a way to speed up the evaluation of
>>
>>Collections
>>
>>>>from within the debugger.
>>>>
>>>>Tim
>>>>
>>>>"Ash Searle" <no_mail@jetbrains.com> wrote in message
>>>>news:9749386.1075386427477.JavaMail.itn@is.intellij.net...
>>>>
>>>>
>>>>>I've also been experiencing this. Our project is running on WebLogic
>>>>
>>>>using JDK1.3.1.
>>>>
>>>>
>>>>>I have found removing the -server option from the java command line
>>
>>helps
>>
>>>>a lot, but the debugger is still nowhere near as fast as the IDEA 3.0
>>
>>users
>>
>>>>here.
>>>>
>>>>
>>>>
>>
>>


0
Comment actions Permalink

That was it! Wow, what a difference; I can actually debug again.

The text of that checkbox should be changed to: "Make debugging painfully
slow"

Thank you, thank you, thank you.

Tim

"Tim Haley" <ymaraner@yahoo.com> wrote in message
news:bvbbdk$loj$1@is.intellij.net...

Never mind, I found it using IDEA Help. Imagine that!

>

BTW, It was on.
I'll try it after turning it off.

>

Tim

>

"Tim Haley" <ymaraner@yahoo.com> wrote in message
news:bvbb7n$km2$1@is.intellij.net...

I vaguely remember that option from previous builds but I can't find it

now.

Where do I (un)set it?

>

"Nathan Brown" <nedski@yahoo.com> wrote in message
news:bvba6e$bak$2@is.intellij.net...

Do you have the alternative view for collections switched on?

>

N.

>

Tim Haley wrote:

>

I've been seeing it as well. Also with WebLogic 7.0.1.0 and

JDK1.3.1.

>

I've noticed that there is often message text that says something

about

evaluating Collection.isEmpty() or Collection.size(). Even after

all

of

the

other variable values are displayed in the Frame tab, any

collections

take

many seconds to be evaluated. Once all of the variables are

evaluated,

the

GUI is responsive until it needs to evaluate variables again.
It seems to be much more responsive when there are no Collections or

Maps in

the current Frame. (Not a common occurrence when working with a J2EE

Web

App.
I could try to avoid the Collections framework, but that would be a
nightmare.

>

Please, please, please, find a way to speed up the evaluation of

Collections

from within the debugger.

>

Tim

>

"Ash Searle" <no_mail@jetbrains.com> wrote in message
news:9749386.1075386427477.JavaMail.itn@is.intellij.net...

>
>>I've also been experiencing this. Our project is running on

WebLogic

>

using JDK1.3.1.

>
>>I have found removing the -server option from the java command line

helps

>

a lot, but the debugger is still nowhere near as fast as the IDEA

3.0

users

here.

>
>
>

>
>

>
>


0
Comment actions Permalink

The problem you described is not in debugger, but in JVM that slows down on stepping over coslty methods.

0
Comment actions Permalink

Please, right click in Frame view and select 'Customise'. Turn off alternative view for collection classes, turn types to be shown as to string to none. On debugger toolbar uncheck 'Suspend all threads while steppong' button. Please, tell whether you have problems in such configuration.

0
Comment actions Permalink


Excellent.

For anyone else needing this:
When debugging, select 'Customize View...' from the context menu in the 'Frame' pane. Uncheck 'Alternate view for Collections classes'.

I really think this option should default to 'off'. The debugging performance is simply unacceptable out-of-the-box.

0
Comment actions Permalink

If you step / resume execution when debugger evaluates alternative views for the variables only currently evaluated Collection.isEmpty() or Collection.size(). method will be invoked. All other evaluations will be ignored and step/resume command will be executed.

Consequently, evaluation speed for Collection classes is not quite nesessary.

0
Comment actions Permalink

Also, don't set breakpoints that use conditions, or print evaluated expressions.

0
Comment actions Permalink

I'm not sure what you mean by that statement, but it sort of sounds like you are saying collection views are eval'd in the background so stepping speed is not affected. That may be the design but the reality is that checking that box literally slows the debugger stepping down by at least 10x. I was thinking it had something to with having 20+ modules in one project with many files...but no, after unchecking the Alternate View for Collection Classes checkbox, it was super-speedy again. I'm just glad I read this forum thread...

0
Comment actions Permalink

Even with all the tips you mentioned stepping to the next line takes 5 seconds. This certainly isn't debugging with pleasure ;-(
I am now using build 1131 and don't see any performance improvements. The strange thing is that CPU load remains almost zero.
With simple projects debugging is much, much faster, so I guess is has to do with having 30 modules set up in my project.

0
Comment actions Permalink

In article <17888069.1075807400883.JavaMail.itn@is.intellij.net>,
mail@gremlin.info says...

Even with all the tips you mentioned stepping to the next line takes 5 seconds. This certainly isn't debugging with pleasure ;-(
I am now using build 1131 and don't see any performance improvements. The strange thing is that CPU load remains almost zero.
With simple projects debugging is much, much faster, so I guess is has to do with having 30 modules set up in my project.

I am seeing the same behavior using remote debugging with 1131. My
project has only two modules. Each step takes about 5 seconds, but CPU
usage remains near zero. It makes the debugging process infuriating!

Regards,

Danny

0
Comment actions Permalink

Hooray. Build 1136 did the trick. Even with both "Suspend all Threads" and "Alternative View for Collection classes" debugging is very fast!

0
Comment actions Permalink

Yeah, absolutely! 1136 is back to Ariadna performance now on stepping,
maybe even faster! I'm very glad you managed to fix this problem before
release... what happened, was there a stray Thread.sleep() somewhere? ;)

N.

Stephen Kelvin wrote:

Hooray. Build 1136 did the trick. Even with both "Suspend all Threads" and "Alternative View for Collection classes" debugging is very fast!

0
Comment actions Permalink

Stephen Kelvin wrote:

Hooray. Build 1136 did the trick. Even with both "Suspend all Threads" and "Alternative View for Collection classes" debugging is very fast!


indeed, 1138 switches to idea very fast when debugging a web app. the
second I hit submit on a form in my browser, it hits the break point.
very very nice.

R

0
Comment actions Permalink

No, just a simple optimization trick to refresh data lazily on demand instead of refreshing it in any case.

0

Please sign in to leave a comment.