IntelliJ 8.1.3 really slow debugging

Hey,

Last week I upgraded IntelliJ 6 to IntelliJ 8.1.3.  However now my debugger in intelliJ is really slow.

I run the app I'm working with in Debug mode.  Then when any user interaction is required it even takes a second to have a button highlighted.  Pressing such a button has a reaction of several seconds.
When it should open a new screen it also takes minutes instead of seconds.  Even opening a little popup for a datepicker takes 25 seconds.
This behaviour immediately stops when I mute breakpoints and everything works as it should.  However this gives me a serious debugging handicap.
This all happens in client code (Swing).  So this should be independent of any application server.

I'm using IntelliJ IDEA 8.1.3
Maven2
Weblogic 10.3
Java 5
WinXP sp2

6 comments
Comment actions Permalink

Ensure that the "Watch method return value" toogle toolbar is not selected.

0
Comment actions Permalink

Hey thanks,

I'm unsure where I can find this option.  It shouldn't be in the Settings then, I can't find that using the filter in the IDEA settings.

0
Comment actions Permalink

Also make sure you have no Method Breakpoints.  Having even one of these really slows down the debugger.

To check, go to Run -> View Breakpoints
Then click on the Method Breakpoints tab and remove all entries.

1
Comment actions Permalink

I'm unsure where I can find this option.


Please check the toolbar buttons in the debug view.

0
Comment actions Permalink

Thanks, that did it.

I did seem to have a method breakpoint somewhere.

0
Comment actions Permalink

I had the same problem debugging a script with many function calls. I've hidden the window of the call stack in the debugger tab and the debugger has started to run at the usual speed.

0

Please sign in to leave a comment.