Is .cvsignore ignored on CVS import?

Hi, all.

I have a ~/.cvsignore file containing .DS_Store, which should prevent
any of my .DS_Store files from getting into CVS.

I note that if I let IDEA import the project, these are placed in the
repository. Is this by design?

Scott

8 comments

I see that too. I put *.class in my .cvsignore but then my class files are getting picked up when I do an 'Add' of a directory. I'm running Build 1128 on OSX at this point.

0

.cvsignore files don't act recursive. Putting "*.class" on the .cvsignore file just prevent from including class files in the same dir as the .cvsignore

0

Should be fixed in 1134

--
Olesya Smirnova
Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

"Scott Ellsworth" <scott@alodar.com> wrote in message
news:scott-41235A.16480330012004@host98.intellij.net...

Hi, all.

>

I have a ~/.cvsignore file containing .DS_Store, which should prevent
any of my .DS_Store files from getting into CVS.

>

I note that if I let IDEA import the project, these are placed in the
repository. Is this by design?

>

Scott



0

Olesya Smirnova (JetBrains) wrote:

Should be fixed in 1134


Would this include a case where the I have the following dir structure:

webDemo/build/
webDemo/deploy/
webDemo/src/
webDemo/web/
webDemo/.cvsignore
webDemo/Web Demo.iml
webDemo/web.xml

The build and deploy directories are not stored in my cvs tree, so I put
the following in my .cvsignore file:

build
deploy

As the build is my output path and it is automatically excluded, I dont
see that directory in the project view - but the deploy directory is
shown (and I would like it to continue to be for debugging purposes).
However in build #1128 it shows deploy as maroon (the colour for "not
added") instead as grey (the old colour for "ignored"). This used to
work in previous builds.

If this is fixed then I'll just upgrade, otherwise I'll file a SCR.

0

Ignored files will be shown in the "Add to CVS" tree but they should be
"unchecked" (otherwise there will be no ability to add into cvs "ignored by
default" files and directories like "core" or "tags")

--
Olesya Smirnova
Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

"Aye Thu" <thua@usa.redcross.org> wrote in message
news:22699238.1075579008304.JavaMail.itn@is.intellij.net...

I see that too. I put *.class in my .cvsignore but then my class files

are getting picked up when I do an 'Add' of a directory. I'm running Build
1128 on OSX at this point.


0

In article <bvlg5f$u79$1@is.intellij.net>,
"Olesya Smirnova \(JetBrains\)" <lesya@intellij.com> wrote:

Ignored files will be shown in the "Add to CVS" tree but they should be
"unchecked" (otherwise there will be no ability to add into cvs "ignored by
default" files and directories like "core" or "tags")


Does that tree come up if you do an Import, rather than an add? I did
not see it when I tried an Import... with 1131.

Scott

0

Do you mean will ignored files imported to the cvs or not? They shouldn't,
but this is fixed in 1134 only

--
Olesya Smirnova
Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

"Scott Ellsworth" <scott@alodar.com> wrote in message
news:scott-CF59C7.11212102022004@host98.intellij.net...

In article <bvlg5f$u79$1@is.intellij.net>,
"Olesya Smirnova \(JetBrains\)" <lesya@intellij.com> wrote:

>

Ignored files will be shown in the "Add to CVS" tree but they should be
"unchecked" (otherwise there will be no ability to add into cvs "ignored

by

default" files and directories like "core" or "tags")

>

Does that tree come up if you do an Import, rather than an add? I did
not see it when I tried an Import... with 1131.

>

Scott



0

In article <bvnt2u$pg4$1@is.intellij.net>,
"Olesya Smirnova \(JetBrains\)" <lesya@intellij.com> wrote:

Do you mean will ignored files imported to the cvs or not? They shouldn't,
but this is fixed in 1134 only


Gotcha - thanks.

Scott

"Scott Ellsworth" <scott@alodar.com> wrote in message
news:scott-CF59C7.11212102022004@host98.intellij.net...

In article <bvlg5f$u79$1@is.intellij.net>,
"Olesya Smirnova \(JetBrains\)" <lesya@intellij.com> wrote:

>

Ignored files will be shown in the "Add to CVS" tree but they should be
"unchecked" (otherwise there will be no ability to add into cvs "ignored

by

default" files and directories like "core" or "tags")

>

Does that tree come up if you do an Import, rather than an add? I did
not see it when I tried an Import... with 1131.

>

Scott

>

0

Please sign in to leave a comment.