Make (button) not doing anything

First off, I'm brand new to IntelliJ and I'm trying to get it working on two different systems:

System 1) my laptop MacBook Pro running snow leopard (coreDuo) 32bit

System 2) my MacPro running snow leopard server. (2x Quad) 64bit


I have a maven project that I've been working on over the past 2 years in JBoss Dev Studio and I've imported it into an IntelliJ project on my Laptop (system 1) and everything works perfectly, i.e. clicking the make button in the tool bar show the little spinning wheel in the status bar, and I can deploy the code to JBoss as an exploded EAR and debug.  IT's a dream.

The problem is that when I do the exact same steps as I did on System 1, nothing builds or runs. If I click the Make button nothing happens in the status bar, if I click debug jboss won't start.

In trouble shooting my issue I tried to just create new Java Projects with a single class with a main(String[] args)  and it works great on System 1) but doesn't work at all on system 2).

So is this a 64bit issue?  I've tried ideas in this post http://www.jetbrains.net/devnet/docs/DOC-1114 didn't make any difference.

I'm totally lost and just purchased the commercial version, and I'm dead in the water on my main computer.  works great on my laptop.


any help would be great.

Thanks,
Pucky Loucks
MacYak Networks

3 comments
Comment actions Permalink

Look in the log file to see if any exceptions are reported. The log file can be found in
~/Library/Caches/IntelliJIDEA8x/log

Bas

0
Comment actions Permalink

Thanks for pointing me at this log file.  I do see an error in it.

When I click the Make Project button the following prints to the log file:

========= LOG FILE SNIP ===============

2009-10-09 11:49:36,831 [ 282830]  ERROR - com.intellij.ide.IdeEventQueue - Error during dispatching of java.awt.event.MouseEvent[MOUSE_RELEASED,(342,30),absolute(352,52),button=1,modifiers=Button1,clickCount=1] on frame1
java.lang.AssertionError: Virtual file not found for /Network/Servers/[FQDN OF MY SERVER]/Users/pucky/Library/Caches/IntelliJIDEA8x/compiler/extranet_maven.sdlcextranet56226384/.generated/Groovy_to_java_source_code_generator/identity-management.f1e133ab/production
 at com.intellij.compiler.impl.CompileDriver.b(CompileDriver.java:205)
 at com.intellij.compiler.impl.CompileDriver.<init>(CompileDriver.java:40)
 at com.intellij.compiler.CompilerManagerImpl.make(CompilerManagerImpl.java:107)
 at com.intellij.compiler.actions.CompileDirtyAction.doAction(CompileDirtyAction.java:7)
 at com.intellij.compiler.actions.CompileActionBase.actionPerformed(CompileActionBase.java:15)
 at com.intellij.openapi.actionSystem.impl.ActionButton.a(ActionButton.java:61)
 at com.intellij.openapi.actionSystem.impl.ActionButton.a(ActionButton.java:89)
 at com.intellij.openapi.actionSystem.impl.ActionButton.processMouseEvent(ActionButton.java:23)
 at java.awt.Component.processEvent(Component.java:6113)
 at java.awt.Container.processEvent(Container.java:2085)
 at java.awt.Component.dispatchEventImpl(Component.java:4714)
 at java.awt.Container.dispatchEventImpl(Container.java:2143)
 at java.awt.Component.dispatchEvent(Component.java:4544)
 at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4618)
 at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4282)
 at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4212)
 at java.awt.Container.dispatchEventImpl(Container.java:2129)
 at java.awt.Window.dispatchEventImpl(Window.java:2475)
 at java.awt.Component.dispatchEvent(Component.java:4544)
 at java.awt.EventQueue.dispatchEvent(EventQueue.java:635)
 at com.intellij.ide.IdeEventQueue.c(IdeEventQueue.java:35)
 at com.intellij.ide.IdeEventQueue.b(IdeEventQueue.java:223)
 at com.intellij.ide.IdeEventQueue.dispatchEvent(IdeEventQueue.java:217)
 at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:296)
 at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:211)
 at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:201)
 at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:196)
 at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:188)
 at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
2009-10-09 11:49:36,831 [ 282830]  ERROR - com.intellij.ide.IdeEventQueue - IntelliJ IDEA 8.1.3  Build #9886
2009-10-09 11:49:36,831 [ 282830]  ERROR - com.intellij.ide.IdeEventQueue - JDK: 1.6.0_15
2009-10-09 11:49:36,831 [ 282830]  ERROR - com.intellij.ide.IdeEventQueue - VM: Java HotSpot(TM) Client VM
2009-10-09 11:49:36,831 [ 282830]  ERROR - com.intellij.ide.IdeEventQueue - Vendor: Apple Inc.
2009-10-09 11:49:36,832 [ 282831]  ERROR - com.intellij.ide.IdeEventQueue - OS: Mac OS X
2009-10-09 11:49:36,832 [ 282831]  ERROR - com.intellij.ide.IdeEventQueue - Last Action: CompileDirty







=====================================


Could this be due to the fact that it's looking at the /Network/Servers Path to my home directory?

Pucky
0
Comment actions Permalink

Well I found out how to fix the issue.  I made sure my user account was set to be a mobile account even when it's on the server. Now IntelliJ looks at /Users/pucky rather than the network path of /Network/Server/[FQDN]/Users/pucky.

So I would consider this a bug with intellij or mac.  for example let's say that the Developers are working on dev workstations in a Leopard or SnowLeopard Network.  If the Sys Admin had there accounts configured to work off the server rather than a mobile account, then this would cause issues.

Anyway making sure my account was set to mobile even if I'm on the Main server fixed the issue.

thanks for pointing me at the logfile.

Cheers,
Pucky

0

Please sign in to leave a comment.