Debugger still has problems in 1128

This tracker was fixed in 1120, but I'm still getting the same behavior.

http://www.intellij.net/tracker/idea/viewSCR?publicId=27098

Evaluation is still useless in this build (inc. alt collection views, and toString() evals).

Also, even with all evaluations turned off, the debugger still gets in a bad state sometimes. After debugging my app for 2 minutes, I stopped at a breakpoint. I think this was my second or third breakpoint. I switched to another file and edited that file, though I didn't recompile. I moved back to the current execution point and hit resume. The debugger tab looked like it had resumed, but my app didn't appear to resume (it didn't repaint). I paused, and selected the event dispatch thread, and saw that it was still stuck on the line with the breakpoint. I tried to step over it, but the step never finished, so I paused again. I tried playing with the "Stop all threads while stepping" option while I resumed and paused, but that didn't make a difference. The application just never resumed.

Please sign in to leave a comment.