Groovy/Grails facet missing from 10762 and 10781 Maia EAP builds

I've tried both 10762 and 10781 and in both builds, when I a) open an existing project or b) create a new project from existing sources, in both cases, the Grails/Groovy facet no longer exists. As such I am unable to specify the Grails SDK anywhere.

Is this expected behaviour i.e. has this functionality moved to some other part of IDEA? Furthermore, none of the grails-app folders are marked as source folders. All seems very broken. Anybody else seeing this behaviour?

5 comments
Comment actions Permalink

The Groovy and Grails facet become obsolete in Intellij 9 as explain in its blog

http://blogs.jetbrains.com/idea/2009/09/groovy-related-configuration-changes/#comments

"Also, you can now write Groovy code and get full coding assistance with compilation as long as you have Groovy jars anywhere in a module classpath. Together with the new compiler Resource patterns path constraints feature (/ - path separator; /**/ - any number of directories) this made Groovy facet obsolete. So, there is no Groovy facet anymore.

You can still add any Gr8 libraries to a module via Add Framework Support context action:"

0
Comment actions Permalink

Ok, I thought I'd read that somewhere but could not find it again. Thanks for the link.

However, 10762 and 10781 do not provide any place for me to change Grails SDK that I can find. It does not recognize the Grails module so defaults it to a Java module, and if you are opening up an existing project, even with the convert to new format, it still contains references to the previous Grails SDK that I no longer wish to reference.

I tried resetting everything, nuking the .grails folder, the Intellij folders, but nothing helped. I've since gone back to the 8.1.3 build which thankfully still works. But the EAP is a no go zone for me right now unfortunately.

0
Comment actions Permalink

Hi,
what happen is this.

For new grails project, Intellij will ask for Grails SDK path explicitly. Upon creating the project, it actually create a library for Grails as shown in the attached image.

HOwever , if you using existing project and you need to modify/add the path of Grails SDK, it seems that it can only do so in Grail Library path settings.



Attachment(s):
0006.jpg
0
Comment actions Permalink

Thanks for the reply.

So if I want to change my Grails SDK, do I then manually need to import all the relevant JAR's etc as a library? Previously you just specify the root folder of the Grails SDK and it imports all the relevant JAR's etc for you.

thanks,
Darryl

0
Comment actions Permalink

The facet isn't needed anymore, having Grails library in module
classpath is sufficient. You may add it there manually on Classpath tab
in module settings.

0

Please sign in to leave a comment.