Automatic compile has stopped working in IDEA 8.x and 9M1+EAP

Suddenly I have to manually trigger compilation of all classes I change. Nothing is automatically picked up. This happens for all versions I have installed; basically almost every version in the 8.x series, 9M1, and the Maia EAP.

This is on OS X, running with SDK 1.6.0_15.

I've tried deleting all traces of IDEA (application, preferences, and cache), re-installing with specific set of plugins and re-installing with just default set of plugins. Since this happens across versions it might seem like it's caused by something else than idea itself, but I see no errors or warnings during startup.

Any ideas?

4 comments
Comment actions Permalink

I am experiencing the same problem with 8.x and 9M1+EAP, although I'm on Ubuntu Karmic. Any luck figuring out what's going on?

0
Comment actions Permalink

Hi!

I am experiencing the same problem with 8.x and 9M1/EAP. Any luck figuring out what's going on?


With "automatic compile" I guess you mean that IDEA is compiling your
project when you run a program from within?

If so, in the run configuration "edit configuration" did you notice the
little "Make" checkbox which might be unchecked?

You can do two things now, check this box for each run configuration, or,
edit the default by clicking on the "Edit defaults" toolbar icon where you
can set the default value for the "make" setting.
I do not know, if this is honored then for already existing configurations.

Ciao,
Mario

0
Comment actions Permalink

If so, in the run configuration "edit configuration" did you notice the
little "Make" checkbox which might be unchecked?


Note, that this "Make" is different from the manually invoked Make. For
example, we have a plugin-module which is no dependency of our main
application's module. If we change something in the plugin-module, we have
to trigger Make manually to make it compile, otherwise it will only compile
changes in the main application's module and all required modules.

Tom

0
Comment actions Permalink

The "make" checkbox in defaults is not honored for existing configurations. Furthermore everytime you switch between 8.x and 9 EAP the "make" checkbox will become unchecked in defaults and all configurations of any projects you open.

Bas

0

Please sign in to leave a comment.