Firefox as Debugger Browser for Flex

I'm having trouble using Firefox as my debugging browser for a Flex project.

When I just click "Run" (i.e. no debug) it launches in Firefox. However, when I debug it launches in Internet Explorer.

In Settings > Web Browsers I have tried both "use system default browser" and "use" with the browser set to Firefox.

Can you let me know how I can lauch in debug mode with Firefox?

Thanks,

Nick

(I'm on Windows 2008 server and using IDEA 8.1)

2 comments
Comment actions Permalink

Unfortunately it's the behavior of Flex debugger tool. Adobe Flash Player Debugger (fdb.exe) itself determines what browser to start. On Windows it calls following system command:
cmd /c ftype http
and uses returned value to launch debugged application.
If you launch *.swf as a file (not via URL or html wrapper) then Adobe Flash Player Debugger will choose how to launch it using following command:
cmd /c ftype ShockwaveFlash.ShockwaveFlash

This problem of Flex debugger is workarounded in latest IntelliJ IDEA (Maia) EAPs and now IDEA respects 'Web Browsers' settings. Download page is http://www.jetbrains.net/confluence/display/IDEADEV/Maia+EAP . If you keep using IDEA 8.1.x then you should change ftype association manually - just run from command line:
cmd /c ftype http "C:\Program Files\Mozilla Firefox\firefox.exe"

0

Please sign in to leave a comment.