Invalid IDEA SDK

Hey guys,

Im on snow leopard and trying to configure my first plugin development project. However, whenever i choose my intelij install, it always tells me that it is invalid location for IDEA sdk. Moreover, i've downloaded the plugin development kit, installed that into my IDEA app (which is very, very tricky to do on OSX and not user friendly at all) but yet still no dice... When the window pops up asking me to choose project SDK, there is nothing to choose from so i click configure, then ok, then I get the error about invalid sdk location or whatever.

Can someone point me in the direction to fix this - right now im considering ditching IDEA and writing the plugin for eclipse / netbeans im that frustrated!

Any advice would be much appreciated

Cheers,

Tim

4 comments
Comment actions Permalink

Hello Tim,

This is a known issue which will be fixed soon:
http://www.jetbrains.net/jira/browse/IDEA-24484

Im on snow leopard and trying to configure my first plugin development
project. However, whenever i choose my intelij install, it always
tells me that it is invalid location for IDEA sdk. Moreover, i've
downloaded the plugin development kit, installed that into my IDEA app
(which is very, very tricky to do on OSX and not user friendly at all)
but yet still no dice... When the window pops up asking me to choose
project SDK, there is nothing to choose from so i click configure,
then ok, then I get the error about invalid sdk location or whatever.

Can someone point me in the direction to fix this - right now im
considering ditching IDEA and writing the plugin for eclipse /
netbeans im that frustrated!

Any advice would be much appreciated


--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Hey!

Thanks for the response - any idea when it'll be fixed? Will there be a bug patch before v9 is released?

Cheers, Tim

0
Comment actions Permalink

Hello Tim,

Thanks for the response - any idea when it'll be fixed? Will there be
a bug patch before v9 is released?


We plan to include the fix for this problem in the 8.1.4 update.

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Sounds good - please excuse my ignorance, but when might that be?

Thanks again for your prompt and helpful answers

Cheers, Tim

0

Please sign in to leave a comment.