Setting the Flex Debugger player

I have a project setup in IntelliJIDEA(8.1.3 B9886)  using Maven(2.09) and Flex(3.3.0 B4852) on Suse Linux( 11.0). When I Run the application the Firefox browser comes up as expected and the app runs fine. When i set a break point and run the debugger however, the application comes up in Flash Player 10. We are targeting player 9 so would like to debug in Flash Player 9 at least, but better would be player 9 in the browser.  I'm at a loss as to where to set the debug 'player'.  Could someone point me in in the right general direction or throw me a clue?

I've gone through the Project Structure settings and nothing points to anything that resembles player 10. The SDK settings seem to point to player 9 (  <FlexSDK>/frameworks/libs/player/9/playerglobal.swc).

I'm just not sure where to look, being relatively new to IntelliJ.  Any help would be appreciated!

Cheers
Cam

1 comment
Comment actions Permalink

Looking in the source of Flex debugger (SDK 3.3.0.4852) we may find that executables are hardcoded there. In case of Linux it launches "firefox" for urls and html files and "flashplayer" in case of swf files. So you may configure your OS so that flashplayer 9 is launched by default. Or launch Flex application via html wrapper and thus Firefox will be launched.

IntelliJ IDEA 9 EAP has some improvements in this area. When Flex application is launched by url or html wrapper IDEA starts browser that is configured in Settings | IDE Settings | Web Browsers. There's also request to configure desired Flash player, but it's not resolved yet: http://www.jetbrains.net/jira/browse/IDEADEV-38601

0

Please sign in to leave a comment.