When the debugger goes missing...

I'm running into this persistent problem with the application that I work with where it is just hanging.  I'm trying to see the threads to get an idea of what is going on.  I tried dumping threads while running in Idea, but there was no output.  I tried running in the debugger, but when I hit pause, I don't see any threads in the drop down menu of running threads and the pause menu stays grey, so the only option I have at that point is to kill the debugger.

Is this a common problem?  I've seen it from time to time, but would like to know what's going on that is preventing Idea from showing the threads.  My CPU is almost completely idle while all of this is going on, so it appears something is just hung.  I'm running the latest IntelliJ 8 version.

1 comment
Comment actions Permalink

Try taking IDEA out of the equation and grab a stack dump with jstack, jconsole,
visualvm etc instead.

AK> I'm running into this persistent problem with the application that I
AK> work with where it is just hanging. I'm trying to see the threads
AK> to get an idea of what is going on. I tried dumping threads while
AK> running in Idea, but there was no output. I tried running in the
AK> debugger, but when I hit pause,
AK> I don't see any threads in the drop down menu of running threads
AK> and the pause menu stays grey, so the only option I have at that
AK> point is to kill the debugger.
AK> Is this a common problem? I've seen it from time to time, but would
AK> like to know what's going on that is preventing Idea from showing
AK> the threads. My CPU is almost completely idle while all of this is
AK> going on, so it appears something is just hung. I'm running the
AK> latest IntelliJ 8 version.


0

Please sign in to leave a comment.