Maven Local Repo Not Recognized

I am trying to use hibernate3-maven-plugin in Maven within IDEA 8.1.3, but I needed to install ojdbc6.jar into my local repository.  I did so from the command line (would be nice to do this from IDEA by the way), and I have verified that the jar is in my local repository.  Also, I cut and pasted the content from maven-metadata-local.xml into my pom file to make sure there would be no issues with the values.  Here is what I added to my pom:

<dependency>
                        <groupId>com.oracle.jdbc</groupId>
                        <artifactId>ojdbc6</artifactId>
                        <version>11.1.0.7.0</version>
</dependency>

When I do that, the version value 11.1.0.7.0 remains red while the others appear correct.  Then when I try to execute the plugin, I get these errors:

Downloading: http://repo1.maven.org/maven2/com/oracle/jdbc/ojdbc6/11.1.0.7.0/ojdbc6-11.1.0.7.0.pom
[INFO] Unable to find resource 'com.oracle.jdbc:ojdbc6:pom:11.1.0.7.0' in repository central (http://repo1.maven.org/maven2)
Downloading: http://repo1.maven.org/maven2/com/oracle/jdbc/ojdbc6/11.1.0.7.0/ojdbc6-11.1.0.7.0.pom
[INFO] Unable to find resource 'com.oracle.jdbc:ojdbc6:pom:11.1.0.7.0' in repository central (http://repo1.maven.org/maven2)

Why is IDEA not looking at my local repository for the file I installed?  And why is the version value still red while the groupId and artifactId are black and presumably correct?

Any insight is appreciated.  Thanks.

Please sign in to leave a comment.