Jboss remote debugging not working

Hi
I'm not able to have Idea 8.1.3 to remote debug Jboss 4.3.0.GA.

IntelliJ run/debug configuration asks for JNDI port, and I keep getting Unable to connect to :  myhost:JNDI  port.  message box. It seams odd that it's not using myhost:port as specified in the remote connection settings. I have it set to use socket, using same port number as the jboss is listening for.

Also, how do I find out the JNDI port that jboss is set to?

any help is appreciated.

thanks.

Paulo

1 comment
Comment actions Permalink

The JNDI port is used to communicate with the application server itself,
not with the debugger. So it isn't related in any way to the debugger port.

By default the JNDI port is set to 1099.

You find the current JNDI port setting in jboss-service.xml:

... ... 1099]]>


On 8/10/2009 11:20 PM, Paulo Avelar wrote:

Hi
I'm not able to have Idea 8.1.3 to remote debug Jboss 4.3.0.GA.

>

IntelliJ run/debug configuration asks for JNDI port, and I keep getting Unable to connect to : myhost:JNDI port. message box. It seams odd that it's not using myhost:port as specified in the remote connection settings. I have it set to use socket, using same port number as the jboss is lestening
for.

>

Also, how do I find out the JNDI port that jboss is set to?

>

any help is appreciated.

>

thanks.

>

Paulo

>

---
Original message URL: http://www.jetbrains.net/devnet/message/5243339#5243339


--
Martin Fuhrer
Fuhrer Engineering AG
http://www.fuhrer.com

0

Please sign in to leave a comment.