GWT launcher takes nowhere defined module to run. How to fix it?

Hi,
I have a GWT 1.6 with maven project and using Maia 10322.
I have a few modules in src/main/java and 1 module in src/test/java.

Sometime, when I have a ability to run GWT app (sometimes it crashes -> http://www.jetbrains.net/devnet/thread/282018) I'm trying to run module from src/main/java. After opening the GWT HostedMode window I see the error, that module <name> doesn't have sources and the question "Did you forget....".


1) This is because that module is in the test sources directory?

2) Why GWT asking me about it? I nowhere defined the path or whatever to this module from src/test/java... Maybe IDEA or maven gives the whole path to GWT launcher?

In Eclipse it works well.

Thanks for the help,
Leszek

3 comments
Comment actions Permalink

Nobody had this problem?

0
Comment actions Permalink

Will be fixed in next EAP build. Thank you for reporting.

Hi,
I have a GWT 1.6 with maven project and using Maia 10322.
I have a few modules in src/main/java and 1 module in src/test/java.

Sometime, when I have a ability to run GWT app (sometimes it crashes -> http://www.jetbrains.net/devnet/thread/282018) I'm trying to run module from src/main/java. After opening the GWT HostedMode window I see the error, that module <name> doesn't have sources and the question "Did you forget....".


1) This is because that module is in the test sources directory?

2) Why GWT asking me about it? I nowhere defined the path or whatever to this module from src/test/java... Maybe IDEA or maven gives the whole path to GWT launcher?

In Eclipse it works well.

Thanks for the help,
Leszek

---
Original message URL: http://www.jetbrains.net/devnet/message/5239332#5239332



--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0

Please sign in to leave a comment.