Anyone have 8.x running on OS X 10.6 (Snow Leopard DP)?

I'm specifically trying on a 32-bit Intel (Core Duo) Mac.  Have not tried on a Duo (64-bit).

For 8.x I get no errors, but it just sort of hangs there and doesn't even show splash screen.  It's running in the Dock and I get the app  name menu, but nothing in it or anything.

for 9.x (figured I'd give it a shot) it looks like Apple moved/removed the L&F classes it expects:


7/6/09 11:45:54 AM [0x0-0x24024].com.jetbrains.intellij[410] Caused by: java.lang.NoClassDefFoundError: apple/laf/CoreUIControl
7/6/09 11:45:54 AM [0x0-0x24024].com.jetbrains.intellij[410] at com.apple.laf.AquaLookAndFeel$1.run(AquaLookAndFeel.java:123)
7/6/09 11:45:54 AM [0x0-0x24024].com.jetbrains.intellij[410] at java.security.AccessController.doPrivileged(Native Method)
7/6/09 11:45:54 AM [0x0-0x24024].com.jetbrains.intellij[410] at com.apple.laf.AquaLookAndFeel.initialize(AquaLookAndFeel.java:120)
7/6/09 11:45:54 AM [0x0-0x24024].com.jetbrains.intellij[410] at javax.swing.UIManager.setLookAndFeel(UIManager.java:544)
7/6/09 11:45:54 AM [0x0-0x24024].com.jetbrains.intellij[410] at javax.swing.UIManager.setLookAndFeel(UIManager.java:589)
7/6/09 11:45:54 AM [0x0-0x24024].com.jetbrains.intellij[410] at com.intellij.idea.MainImpl.start(MainImpl.java:36)
7/6/09 11:45:54 AM [0x0-0x24024].com.jetbrains.intellij[410] ... 6 more



 


While that's interesting, I'm much more interested in getting 8.x to work.  I can get it to launch by re-sym-linking the "A" directory (which is the old OSX 10.5 version of Java 5, which seems to be completely gone in OSX 10.6) in the Java versions folder (where OS X keeps all it's versions of Java) but have to sym-link back to "1.6" to actually run anything else (or do anything on command-line, since I'm working in Java 6, not 5).

The problem with my little "fix", is that IDEA freaks out when I do the sym-link dance and can't find any libs or even handle subversion info properly.

Would appreciate any help!

Please sign in to leave a comment.