IBM (Synaptics) TrackPoint Scrolling

One of my main IDEA annoyances has long been that the scrolling features of my ThinkPad's TrackPoint (made by Synaptics) did not work. I just discovered that adding the following lines to tp4table.dat just below the "Java support" section in Synaptics\SynTP\tp4table.dat fixes the problem completely (after a reboot):

This may not be the most appropriate forum for this tip, but I'm sort of hoping that the IntelliJ folks will be able to convince Synaptics people (or get the LaunchAnywhere folks to do so) to add these lines (or similar settings) in the default install some time in the longer term future so IDEA users don't have to do so manually.

8 comments
Comment actions Permalink


"Michael Werle" <mkwerle@yahoo.com> a écrit dans le message de
news:81604.1074055436289.JavaMail.itn@is.intellij.net...

One of my main IDEA annoyances has long been that the scrolling features

of my ThinkPad's TrackPoint (made by Synaptics) did not work. I just
discovered that adding the following lines to tp4table.dat just below the
"Java support" section in Synaptics\SynTP\tp4table.dat fixes the problem
completely (after a reboot):

*,*,idea.exe,*,*,*,WheelStd,1,9]]>
This may not be the most appropriate forum for this tip, but I'm sort of

hoping that the IntelliJ folks will be able to convince Synaptics people (or
get the LaunchAnywhere folks to do so) to add these lines (or similar
settings) in the default install some time in the longer term future so IDEA
users don't have to do so manually.


Oh, that sounds interesting !
On my Sony Vaio, it's a Synaptics touchpad as well
Maybe I'll be able to test your suggestion !
Thanks for the tip.
Andrei Opra and I were a bit annoyed by not being able to scroll with a
touchpad or trackpoint within IntelliJ.

Guillaume Laforge


0
Comment actions Permalink

Guillaume Laforge wrote:

Andrei Opra and I were a bit annoyed by not being able to scroll with a
touchpad or trackpoint within IntelliJ.


There are many more people not happy about it.
BTW I tried that trick on my IBM T23 and didn't work :(

r.

0
Comment actions Permalink

There are many more people not happy about it.


I guess we're not the only ones working on laptops ;)

BTW I tried that trick on my IBM T23 and didn't work :(


And you didn't forget to reboot ?
Oh bad news !
I hope it'll work on my laptop.
We'll see...

Guillaume Laforge


0
Comment actions Permalink

Thanks a lot for the tip, it worked like a charm!

I'm on a T40 IBM ThinkPad and this scrolling thing was driving me nuts.
Especially since I heard that someone else was able to scroll with the
touchpad on a T40. I guess he/she was starting IDEA using the bat file
(since java and javaw were already registered in the tp4table.dat file). Who
would have guessed this could make a difference...

This definitely deserves a wiki entry somewhere, not sure where exactly,
though... :)

Many, many thanks,
Andrei


"Michael Werle" <mkwerle@yahoo.com> wrote in message
news:81604.1074055436289.JavaMail.itn@is.intellij.net...

One of my main IDEA annoyances has long been that the scrolling features

of my ThinkPad's TrackPoint (made by Synaptics) did not work. I just
discovered that adding the following lines to tp4table.dat just below the
"Java support" section in Synaptics\SynTP\tp4table.dat fixes the problem
completely (after a reboot):

*,*,idea.exe,*,*,*,WheelStd,1,9]]>
This may not be the most appropriate forum for this tip, but I'm sort of

hoping that the IntelliJ folks will be able to convince Synaptics people (or
get the LaunchAnywhere folks to do so) to add these lines (or similar
settings) in the default install some time in the longer term future so IDEA
users don't have to do so manually.


0
Comment actions Permalink

Works for me, now. Had scrolling off because of middle click
needs in FireBird.
r.

Guillaume Laforge wrote:
>>There are many more people not happy about it.


I guess we're not the only ones working on laptops ;)

>>BTW I tried that trick on my IBM T23 and didn't work :(


And you didn't forget to reboot ?
Oh bad news !
I hope it'll work on my laptop.
We'll see...

Guillaume Laforge

0
Comment actions Permalink

On a side note, you should be able to modify the settings to make FireBird work as you want in the same file or in SynTPEnh.ini . . . though I'm no expert on either; I only figured out the trick in this tread by noting that scrolling worked in most Java programs but not in IDEA and realizing that the executable name was different.

&gt; Works for me, now. Had scrolling off because of
&gt; middle click
&gt; needs in FireBird.
&gt; r.

0
Comment actions Permalink

Different method

I use a Lenovo ThinkPad USB keyboard with trackpoint and your method did not work for me, because there is no tp4table.dat or a similar file with this option.

I enabled the trackpoint scroll functionality by setting the -Xrs option to the java call in the phpstorm.bat.

More about java -Xrs:
http://www.ibm.com/support/knowledgecenter/SSYKE2_7.0.0/com.ibm.java.aix.71.doc/diag/appendixes/cmdline/Xrs.html

I hope, this does not destroy any other functionality of PhpStorm.

 

-1
Comment actions Permalink

Sorry, the method described above did only work once (next time with PhpStorm the scrolling did not work anymore). I don't get it.

0

Please sign in to leave a comment.