Build.xml opening in editor??

Simple problem. Whenever I build my project, from the menu or from the ant build pane, it all builds as normal, but also opens build.xml in the editor for some reason. I doubt this is a bug, but where the bejeezus do I turn it off?

8 comments
Comment actions Permalink

Simple problem. Whenever I build my project, from the menu or from the
ant build pane, it all builds as normal, but also opens build.xml in
the editor for some reason. I doubt this is a bug, but where the
bejeezus do I turn it off?


I think you probably accidentally enabled the "Jump to Source" toolbar button
on the Ant build toolwindow.


0
Comment actions Permalink

Yeah I've done a "jump to source" from the right-click menu, but I assumed that was an action, not some sort of toggle. How on earth do I turn it off?

0
Comment actions Permalink


Not the right click menu. Check that the toolbar button "Jump to source"
isn't toggled on.


0
Comment actions Permalink

Where's this button supposed to be? Neither my ant build pane nor the main window have a "jump to source" button in the toolbar.

0
Comment actions Permalink

Now that you mention it, the ant panel doesn't have this button. As most
other panels have this button I thought ant also had one.

Can it be that the button is selected in the project/package/... panel and
that this is somehow affecting ant build producing the behaviour you see?

I never turn this on, so I'm not an expert on this feature.


0
Comment actions Permalink

If your build causes an error, the build file is also shown.

Josh McDonald schrieb:

Simple problem. Whenever I build my project, from the menu or from the ant build pane, it all builds as normal, but also opens build.xml in the editor for some reason. I doubt this is a bug, but where the bejeezus do I turn it off?

0
Comment actions Permalink

This question is over four years old now, but I'm seeing this behavior in release 8.1.3.  Is there a solution to this problem?

0
Comment actions Permalink

I found the problem. The "Auto scroll to source" button was checked in the Messages Window that pops up when the ant script runs.

0

Please sign in to leave a comment.