CVS rsh ?

Has anyone got IDEA CVS working with rsh (using :ext:)?
Apart from having to specify a dummy key file (which isnt going to be used), is there anything else I need to setup?
Ive configured the CVS roots, and the "Test Connection" comes back successful,

My CVS root is set as:
:ext:npratt@/home/users/cvs/repo/src/projectname

Path to external rsh: /usr/bin/rsh
Path to private key file: /home/users/npratt/dummy_key.txt
Additional Params: (empty)

I keep getting "broken pipe" and "Error: Valid requests expected!" when I attempt to browse the CVS repo, although the CVS Output window shows the commands as coming back with return code 0 (success I assume).

Solaris 8, EAP 1035

Nick

6 comments
Comment actions Permalink

You should use real private key file or use ssh connection method (in order
to connect using password)

--
Olesya Smirnova
Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

"Nick Pratt" <no_mail@jetbrains.com> wrote in message
news:2576482.1072720418548.JavaMail.itn@is.intellij.net...

Has anyone got IDEA CVS working with rsh (using :ext:)?
Apart from having to specify a dummy key file (which isnt going to be

used), is there anything else I need to setup?

Ive configured the CVS roots, and the "Test Connection" comes back

successful,
>

My CVS root is set as:
:ext:npratt@/home/users/cvs/repo/src/projectname

>

Path to external rsh: /usr/bin/rsh
Path to private key file: /home/users/npratt/dummy_key.txt
Additional Params: (empty)

>

I keep getting "broken pipe" and "Error: Valid requests expected!" when I

attempt to browse the CVS repo, although the CVS Output window shows the
commands as coming back with return code 0 (success I assume).
>

Solaris 8, EAP 1035

>

Nick



0
Comment actions Permalink

But what is a "real" private key file for an rsh connection? i.e. what is the format?

Ive got my uid and host name in my .rhosts file, so its not needed, or shouldnt be.

Nick

0
Comment actions Permalink

Where do I find the ssh connection method in the Aurora release?

Thanks,

Dave Forslund
Olesya Smirnova (JetBrains) wrote:

You should use real private key file or use ssh connection method (in order
to connect using password)


0
Comment actions Permalink

You should check out your project with ":ssh:" method. Why don't you want to
use private key?

--
Olesya Smirnova
Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

"David Forslund" <forslund@mail.com> wrote in message
news:btn1hi$fmd$1@is.intellij.net...

Where do I find the ssh connection method in the Aurora release?

>

Thanks,

>

Dave Forslund
Olesya Smirnova (JetBrains) wrote:

You should use real private key file or use ssh connection method (in

order

to connect using password)

>

>


0
Comment actions Permalink

Our corporate policies do not allow using private key, so I always have
to establish SSH tunnel from the shell. It would be very nice if IDEA
did it itself (possibly achievable by a plugin).

-- dimiter

0
Comment actions Permalink

I realize this is an ancient issue, but I just hit it for the first time today.

Basically, I have NO CHOICE but to use RSH (:ext:) method for connection.  The server I'm attempting to connect to is inside the corporate firewall where I am, and SSH connections were never enabled, and nobody is interested in changing this for what are essentially becoming "legacy" systems.

Since Intellij doesn't appear to support RSH connections for CVS (regardless of whether you think it's a good idea or not), I am reduced to using the command line for VCS operations, and basically using Intellij as a "fancy editor".

Or maybe I'll just go back to Eclipse, since it supports both RSH and SSH connections to CVS, and it also supports Git (and Gerrit.. better than Intellij, though the Intellij plugin has been improving), Subversion, etc. - all the major source control systems, AND all their variations.

0

Please sign in to leave a comment.