Applet problems

Hello,

Here are a few problems I encountered while building applets :

- After editing an Applet run entry, the applet height is
automatically set to the same value as the applet Width.

- MSIE-compatible applets requires a Java 1.1 build before
deploying (compiling with Java 2 make the applet fail to start at
runtime). No IDEA failure here but the problem is that if I
configure an "applet-side" JDK 1.1.8 module and a "server-side"
Java 2 module in the same project, the applet module will always
be compiled using the Java 2 compiler. I expected the JDK 1.1.8
module to use the 1.1.8 compiler. Furthermore, there seem to be
no "rebuild" capability at module-level (only compile).

Thanks for your work,

Jerome.

1 comment
Comment actions Permalink

"Jérôme Beau" <jerome.beau@libelis.com> wrote in message
news:bshib5$ivl$1@is.intellij.net...

Hello,

>

Here are a few problems I encountered while building applets :

>

- After editing an Applet run entry, the applet height is
automatically set to the same value as the applet Width.


Fixed in build 1049.

>

- MSIE-compatible applets requires a Java 1.1 build before
deploying (compiling with Java 2 make the applet fail to start at
runtime). No IDEA failure here but the problem is that if I
configure an "applet-side" JDK 1.1.8 module and a "server-side"
Java 2 module in the same project, the applet module will always
be compiled using the Java 2 compiler. I expected the JDK 1.1.8
module to use the 1.1.8 compiler. Furthermore, there seem to be
no "rebuild" capability at module-level (only compile).

>

Thanks for your work,

>

Jerome.




--

Dmitry Peshehonov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"



0

Please sign in to leave a comment.