intellij 8 - slow

I just installed version 8 and I'm upset that my productivity due to it's slowness has gone down to maybe 10%...what's up with version 8 being very slow while i'm editing and moving around in the editor?

What do I need to turn off so that the editing session can go faster?

Vipin

I should clarify, I was running the pre-release version of 8 and version 7 and they were working just fine on the same machine.

Machine has 2GB and a core-2-duo chip.

Edited by: vipin on Nov 12, 2008 5:05 AM

35 comments
Comment actions Permalink

I just installed version 8 and I'm upset that my productivity due to it's slowness has gone down to maybe 10%...what's up with version 8 being very slow while i'm editing and moving around in the editor?

What do I need to turn off so that the editing session can go faster?

Vipin


My Diana runs quite fast, so that should be your setup.

let's see what I am doing to have it run fast after wasting hours of my time to lousy performance:

  • pointed IDEA_JDK to the latest JDK from Sun, 1.6.0_10.

  • Having plenty of muscle on the box: plenty of RAM, fast CPU and HD.

  • rooted my projects and modules as close to the source root as possible. I had major problems creating the project files several directory levels up from the actual project files location because of version control structuring. Idea was taking long breaks hogging the CPU, the RAM and all then, probably navigating through directory structure where it really should not go in the first place...

  • disabled any plugin that I don't use on a regular basis.

  • enabling version control integration only for refactoring.

  • added this to my idea.vmoptions:

-server
-Xms768m
-Xmx1248m
-Xmn170m
-XX:MaxPermSize=300m


with the -server option being first.

Hope this helps.

0
Comment actions Permalink

Pretty slow for me too. In particular on jsp pages.

0
Comment actions Permalink

I'm using the final release of IntellijJ 8 and it's very slow for me as well. Every time I edit a Java file, Intellij freezes for a few seconds. This is very annoying.

I tried suggestions by Michael but it didn't seem to make a difference for me.

Any ideas?

0
Comment actions Permalink

here's one more trick that helps me:

  • if you have any logging directories off your project root, mark them excluded in the project settings. I found Idea rummaging through those logs picking references to the classes. I found it out doing refactoring: Idea showed me references in the logs that were several directories deep off the project root: like runtime/tests/unit/framework/log. Considering that there were over 100M logs accumulated over weeks of testing... So I marked the whole "runtime" tree as excluded and got some noticeable boost in performance and no more "log spam" on refactoring... Generally I find i8 about as fast (if not faster) than i7 on the same machine with same projects. So it's gotta be something different with those who see it slow.

0
Comment actions Permalink

Thanks for the reply. However, in my project, all the runtime or build directories have been marked excluded. So, this doesn't help me. :(

0
Comment actions Permalink

Disable all the features you don't need for example if your not using Seam, Velocity, Freemarker, GWT, CVS, JUnit/TestNG, Perforce etc. disable all that stuff.

0
Comment actions Permalink
  • enabling version control integration only for refactoring.


We have version control disabled all the time to use external tools.

Tom

0
Comment actions Permalink

Hello vipin,

I just installed version 8 and I'm upset that my productivity due to
it's slowness has gone down to maybe 10%...what's up with version 8
being very slow while i'm editing and moving around in the editor?

What do I need to turn off so that the editing session can go faster?


Unfortunately you haven't provided any details that would allow us to answer
your question. Please take a CPU snapshot as described in http://support.jetbrains.com/kb/entry.jspa?externalID=192&categoryID=5

Note that there is a known performance problem on Ubuntu 8.10 which is caused
by Ubuntu itself and also affects other Java applications, and there's unfortunately
no known workaround for it.

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Hello Yuan-Fang,

I'm using the final release of IntellijJ 8 and it's very slow for me
as well. Every time I edit a Java file, Intellij freezes for a few
seconds. This is very annoying.


Please take a CPU snapshot as described in http://support.jetbrains.com/kb/entry.jspa?externalID=192&categoryID=5

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

I have found IntelliJ 8 to be quite speedy, actually it feels to be the fastest IntelliJ release yet.

The only optimizations I have done are disable plugins I don't use and I run it with the -server VM option set in idea.vmoptions.

I did experience the Ubuntu 8.10 Java problem so I had to wipe it and re-install 8.04. (strangely my co-worker runs Java apps under Ubuntu 8.10 just fine)

0
Comment actions Permalink

So does that mean to 8.0 running in Ubuntu 8.04 is faster for you than with 8.10?
I've got performance problems with 8.10, as well.

0
Comment actions Permalink

how do you set up the vm options on OS X?

0
Comment actions Permalink

IntelliJ was pretty much unusable in Ubuntu 8.10 (as were most Java apps, not just IntelliJ).

In 8.04 IntelliJ is very snappy. Faster than it ever was on Windows.

Please note I was using Ubuntu 8.10 final release candidate, I did not try the 8.10 final. By the time 8.10 final came out I had already wiped 8.10 and went back to 8.04.

Also, I should point out that under 8.10 I was using 7.0.4, not 8.0. However, I am now running IntelliJ 8.0 under Ubuntu 8.04 and it is quite snappy.

0
Comment actions Permalink

I should clarify what I mean by slow. It is fast in terms of responsiveness, like it doesn't hang. What is slow is the Analysis. It takes a long time for it to complete the class analysis, and an even longer time to do it in jsp's so you can't use any intentions or refactorings until it's done. Which makes it much slower in terms of productivity when compared to 7.

0
Comment actions Permalink

You have to edit the Info.plist file in the .app directory. In my case, it's:

/Applications/IntelliJ/IntelliJ\ IDEA\ 7.0.4.app/Contents/Info.plist

Scroll all the way down, and there you can find the configuration.

0
Comment actions Permalink

Default idea.exe.vmoptions has:

-Xms32m
-Xmx256m
-XX:MaxPermSize=120m
-ea

at the last line, -ea parameter means enable assertions which is a performance hit. I wonder why Jetbrains put -ea on default production release? I'm running idea with these options and it's running smooth as we are used to it

-server
-Xms256m
-Xmx512m
-Xmn170m
-XX:MaxPermSize=300m

0
Comment actions Permalink

As with all claims about performance, the appropriate response is "prove it."

Seriously, assertion checking is known to be a trivial overhead. Of course, that doesn't address the cost of evaluating the assertion expression, which is in general an arbitrary computation. We have to rely on the prudence of the IDEA developers not to initiate expensive assertion tests or to put them in inner loops and whatnot.


Randall Schulz

0
Comment actions Permalink

Hi Dmitry, I just got around to take a cpu snapshot. It was taken while I was editing a very simple FreeMarker template file (< 50 lines). Intellij freezes whenver I do some editing. I've uploaded the snapshot to the ftp server and it's called 9013_liyf_14.11.2008_10.33.49.zip.

By the way, I did the performance improvement things suggested above: disk defrag, disabling plugins I'm not using, disabling anti virus software, etc. Seems that they helped a bit but still, Intellij 8 is not as snappy as version 7. I'm running windows though.

My system:
CPU: Pentium 4 3.4GHz
Memory: 2GB
HDD: regular SATA drives (running Windows XP SP2 on NTFS)

0
Comment actions Permalink

Hi Dmitry,

Thanks for the info. I too have just upgraded to Ubuntu 8.10 and IntelliJ 8.0, and find it virtually impossible to work with IntelliJ, when before it was running well (both the 8.0 release candidate and earlier 7.* releases on Ubuntu 8.04).

Before I submit a report as you suggest, I am very interested in reading about this "known performance problem on Ubuntu 8.10" - I've had a look on Ubuntu's bug reporting website () and can't find any reference to it. Can you please point us to a webpage that documents this problem? If it is a known problem, it would be good to know if there is a workaround, or if I should just restrict myself to an earlier version of IntelliJ, or even if IntelliJ will be slow - irrespective of version - on Ubuntu 8.10.

Thanks very much.

0
Comment actions Permalink

Both IntelliJ 7 and 8 are impossible to use under Ubuntu 8.10. I had to downgrade to Ubuntu 8.04 to use IntelliJ in Ubuntu. It wasn't just IntelliJ though, all Java apps were sluggish in Ubuntu 8.10.

I searched the Ubuntu bug database but couldn't find any reference to the problem. My co-worker runs 8.10 and IntelliJ and all java apps run just fine for him. So there must be a magic combination of hardware that triggers the bug.

0
Comment actions Permalink

Hello lister,

Before I submit a report as you suggest, I am very interested in
reading about this "known performance problem on Ubuntu 8.10" - I've
had a look on Ubuntu's bug reporting website
() and can't find any reference to
it. Can you please point us to a webpage that documents this problem?


https://bugs.launchpad.net/ubuntu/source/sun-java6/bug/288650

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

One of the Ubuntu problems: https://bugs.launchpad.net/ubuntu/source/sun-java6/bug/288650

I think this might be related: https://bugs.launchpad.net/ubuntu/source/xorg-server/bug/280671

How slow is your slow?
For me mouse scrolling is fine, keyboard scrolling is slower than usual. Annoying, but usable.

I experimented with the XServer options, enabled exa and that was really slow. Scrolling one page took more than 10 seconds.

0
Comment actions Permalink

Hello Michael,

I searched the Ubuntu bug database but couldn't find any reference to
the problem. My co-worker runs 8.10 and IntelliJ and all java apps run
just fine for him. So there must be a magic combination of hardware
that triggers the bug.


Which video card do you have, and which does your coworker have? Maybe the
issue happens only on integrated Intel video cards and doesn't happen if
you have an NVidia or ATI video card?

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

all Java apps were sluggish in Ubuntu 8.10.


Hm, I don't have that feeling for our applications. It feels snappy and
finally looks good (fonts were always ugly on Linux).

Tom

0
Comment actions Permalink

Some Linux distributions disable FreeType's font hinting for "intellectual property" reasons. Nonetheless, the code is there in the FreeType source, and I always rebuild it (for my SuSE Linux / openSUSE installations) with hinting enabled and then fine-tune my font selections to best exploit the characteristics of the display and the font at the (usually small) size I like.

Parenthetically, I'm very particular about font rendering, though I don't claim that my preferences are in any way "proper" or "universal." I know Apple's rendering is tuned for faithfulness to the original font design, which results in the typically more fuzzy appearance of fonts at smaller sizes on MacOS. I care less about the font designer's intentions and more about sharpness, smoothness and readability at small sizes, and that's what I seek to optimize by my choice of fonts and rendering options.


Randall Schulz

0
Comment actions Permalink

My graphics card:

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)

Co-workers:

Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)



Interestingly my chipset is the same chipset that is listed in the bug: https://bugs.launchpad.net/ubuntu/source/sun-java6/bug/288650

So maybe the problem is limited to this particular chipset or at least a very small sub-set of integrated intel chipsets.

0
Comment actions Permalink

Some people posted on the Ubuntu bugtracker that using XAA instead of EXA solved their problems.

For that they've put
Option "AccelMethod" "XAA"
into the Device section of /etc/x11/xorg.conf.

Section "Device"
Identifier "Configured Video Device"
Option "AccelMethod" "XAA"
EndSection

0
Comment actions Permalink

Hi all,

Thanks very much for the helpful suggestions. My video configuration is:

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)

I had a look at the bug reports, and at what Dmitry and others have said, and tried the XAA option to my xorg.conf.

However, it just results in intellij8 loading up the splash screen and then hanging with the splash screen just sitting there. Any ideas? Perhaps I should also post this on the https://bugs.launchpad.net/ubuntu/source/sun-java6/bug/288650 bug report?

Thanks again!

0
Comment actions Permalink

Just thought I'd update my earlier post. When I couldn't figure out why the loading of intellij would hang on the splash screen, I decided to try to upgrade my build 9013. I've just downloaded build 9164, and that seems to solve the problem. Now intellij loads properly, and it seems to be faster (i.e. I can actually work using it) than it was before I enabled the XAA option. I've also used the GTK+ look and feel, which the recently-posted FAQ item mentioned. This, too, seems to increase the speed. A good workaround until Ubuntu get themselves sorted out. I definitely have one of the chipsets that others have mentioned performs badly with java apps in the latest release of Ubuntu (intrepid ibex). It's still not as fast as when I had Ubuntu Feisty, but it is much better!

Thanks for all the help, especially as it turned out to be a problem with Ubuntu, and not IntelliJ!

0
Comment actions Permalink

It helped. Thank you!

0

Please sign in to leave a comment.