JUnit testing in 996

When I try to run JUnit tests in 996, it takes a very long time to get off the mark (more than a minute); then I get the following exception:
(Reader.java:61) at java.io.InputStreamReader.(InputStreamReader.java:80) at com.intellij.util.JDOMUtil.loadDocument(JDOMUtil.java:36) at com.intellij.openapi.components.a.a.a(a.java:34) at com.intellij.openapi.components.a.a.a(a.java:189) at com.intellij.openapi.components.a.a.e(a.java:135) at com.intellij.openapi.application.a.b.r(b.java:43) at com.intellij.openapi.application.a.b.(b.java:44) at com.intellij.openapi.application.b.b.a(b.java:3) at com.intellij.idea.a.(a.java:16) at com.intellij.idea.b.(b.java:8) at com.intellij.idea.b.a(b.java:5) at com.intellij.testFramework.LightIdeaTestCase.a(LightIdeaTestCase.java:56) at com.intellij.testFramework.LightIdeaTestCase.setUp(LightIdeaTestCase.java:59) at com.wrq.rearranger.RearrangerTest.setUp(RearrangerTest.java:37) at com.intellij.testFramework.LightIdeaTestCase.d(LightIdeaTestCase.java:43) at com.intellij.testFramework.LightIdeaTestCase.access$400(LightIdeaTestCase.java:61) at com.intellij.testFramework.LightIdeaTestCase$5.run(LightIdeaTestCase.java:1) at com.intellij.util.LaterInvokator$1.run(LaterInvokator.java:3) at com.intellij.util.LaterInvokator$FlushQueue.run(LaterInvokator.java:2) at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:178) at java.awt.EventQueue.dispatchEvent(EventQueue.java:454) at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:201) at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:151) at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:145) at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:137) at java.awt.EventDispatchThread.run(EventDispatchThread.java:100) ]]>
Is anybody else having this problem?

-Dave

5 comments

Dave Kriewall wrote:

>When I try to run JUnit tests in 996, it takes a very long time to get off the mark (more than a minute);
>

>

Same problem here : more than a minute before it kicks in.



>then I get the following exception: ...

>

Not here : my tests runs fine.

Alain

0

Over five minutes here, then I killed it and started the old 3.0.5 version. Also, I think the startup time is much longer in 996 than 3.0.5

André

0

The NPE exception seems to be due to com.intellij.testFramework.LightIdeaTestCase.setUp() -- is anybody having success using IDEA's test framework?

Thanks-
-Dave

0

I don't have any problems with it.
I don't have too many tests so far, though, not sure if it makes any
difference.

Andrei

"Dave Kriewall" <no_mail@jetbrains.com> wrote in message
news:21896911.1071589853263.JavaMail.javamailuser@localhost...

The NPE exception seems to be due to

com.intellij.testFramework.LightIdeaTestCase.setUp() -- is anybody having
success using IDEA's test framework?
>

Thanks-
-Dave



0

Dave Kriewall wrote:

>is anybody having success using IDEA's test framework?
>


I do. It's very basic, but it works fine.


Alain

0

Please sign in to leave a comment.