Problem with 963 plugins

Hello,

I have Idea 3.0.5 installed for daily production use and it's working just fine. Then I wanted to try the latest EAP:

I installed Idea EAP build 963 without JRE. Then I added Idea856 JRE package to the IDEA_HOME. I modified IDEA_SYSTEM_PATH to differ from the one that 3.0.5 uses in the idea startup script IDEA_HOME/bin/idea.sh.

Idea 963 starts up nicely and everything seems to be working except UIDesginer and CVS-support is missing. Also the plugin manager displays an error when trying to install any plugin: java.io.FileNotFoundException: bin/../plugins/simpleUML_b15A.jar (No such file or directory).

I even tried manually to put SQL query plugin jar-file in the plugins directory, however the plugin didn't load on idea restart.

There is nothing special in the idea log and plugin-directory has all the build-in plugins.

Any ideas?

-Jani

2 comments

Did you accidentally change the location of the plugins dir in the startup
script?

"Jani Kaarnalehto" <no_mail@jetbrains.com> wrote in message
news:759469.1068806702858.JavaMail.itn@is.intellij.net...

Hello,

>

I have Idea 3.0.5 installed for daily production use and it's working just

fine. Then I wanted to try the latest EAP:
>

I installed Idea EAP build 963 without JRE. Then I added Idea856 JRE

package to the IDEA_HOME. I modified IDEA_SYSTEM_PATH to differ from the one
that 3.0.5 uses in the idea startup script IDEA_HOME/bin/idea.sh.
>

Idea 963 starts up nicely and everything seems to be working except

UIDesginer and CVS-support is missing. Also the plugin manager displays an
error when trying to install any plugin: java.io.FileNotFoundException:
bin/../plugins/simpleUML_b15A.jar (No such file or directory).
>

I even tried manually to put SQL query plugin jar-file in the plugins

directory, however the plugin didn't load on idea restart.
>

There is nothing special in the idea log and plugin-directory has all the

build-in plugins.
>

Any ideas?

>

-Jani

>
>


0

Please sign in to leave a comment.