BUG ClassNotFound Exception

Don't know where to submit this bug, cause i don't found
a way to make a new posting in bugs.

for better understanding, i describe my working
environment. Intellij IDEA runs on my local C: drive,
the project i am working on is on local D: drive,
the output of the compil goes to an ramdrive E:
every morning when i boot my pc, the ramdrive was setup
with nothing on it, then i start IDEA and "run" the
project, for the first time IDEA reminds me, that the
output driectory doesn't exist, i choose create it.
after compiling the project, i receive the following
error:

java.lang.ClassNotFoundException: com.xyz.main.uw.UwApp
at java.net.URLClassLoader$1.run(URLClassLoader.java:199)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:274)
at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:302)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:141)
at com.intellij.rt.execution.application.AppMain.main(AppMain.java:75)
Exception in thread "main" Process terminated with exit code 1

when i start the application a second time,
everything works fine, the problem is the
first run (creation of output dirs, compiling and run).
the second time everything is fine.

hope that this will be fixed in the release of IDEA.
thanks

Please sign in to leave a comment.