Idea 977 not starting with JSDK 1.4.2_02 installed: msg "IDEA requires 1.4.2_02".

I have installed JSDK 1.4.2_02 separate from Aurora and IDEA Aurora 977 from the zip file and I get the following error when trying to start IDEA Aurora 977: "The JDK version is 1.4.2. IDEA requires 1.4.2_02". I've tried with either and both the JRE and the JSDK installed with no success. I have rebooted multiple times during this configuration, as well, including a final reboot.

7 comments

I forgot to mention that I'm using Windows XP SP1.

0

Why don't you use JRE bundled with IDEA?

--
Valentin Kipiatkov
JetBrains, Inc
http://www.intellij.com
"Develop with pleasure!"

"Jerri Kohl" <no_mail@jetbrains.com> wrote in message
news:5801420.1069092098497.JavaMail.itn@is.intellij.net...

I have installed JSDK 1.4.2_02 separate from Aurora and IDEA Aurora 977

from the zip file and I get the following error when trying to start IDEA
Aurora 977: "The JDK version is 1.4.2. IDEA requires 1.4.2_02". I've tried
with either and both the JRE and the JSDK installed with no success. I have
rebooted multiple times during this configuration, as well, including a
final reboot.
>


0

Did you download idea977-jre.zip from the EAP page, unzip it, and place the resulting "jre" directory in your IDEA installation directory?

0

In idea.lax file point to your 1.4.2_02 JRE home then start it.

"Jerri Kohl" <no_mail@jetbrains.com> wrote in message
news:5801420.1069092098497.JavaMail.itn@is.intellij.net...

I have installed JSDK 1.4.2_02 separate from Aurora and IDEA Aurora 977

from the zip file and I get the following error when trying to start IDEA
Aurora 977: "The JDK version is 1.4.2. IDEA requires 1.4.2_02". I've tried
with either and both the JRE and the JSDK installed with no success. I have
rebooted multiple times during this configuration, as well, including a
final reboot.
>


0

Thanks. My previous config for VM in the .lax file had a relative path to the old IDEA JRE. I put an absolute path in to my new 1.4.2_02 JRE, and then I didn't get the same error, but instead IDEA would try to load and a continuous stream of exceptions would pour forth on the console window, ending in IDEA ceasing to run before it properly displayed itself. Using the java.exe in the JRE that came with the JSDK and the one in the JSDK proper resulting in IDEA halting at different points of progress.

As per the previous person's suggestion, I tried the JRE on the Aurora dl page. IDEA now loads, but there is still a fair number of exceptions in the console window and some error dialogs. Why does IDEA require a "special" JRE package? I would really like to see IDEA work with a normal Sun JSDK/JRE install and not require a "special" JRE package.

0

Only for antialized fonts as i can see.
You can't use antialized feature with standard JRE.

That OS system?

"Jerri Kohl" <no_mail@jetbrains.com> wrote in message
news:8409145.1069098977265.JavaMail.itn@is.intellij.net...

Thanks. My previous config for VM in the .lax file had a relative path to

the old IDEA JRE. I put an absolute path in to my new 1.4.2_02 JRE, and then
I didn't get the same error, but instead IDEA would try to load and a
continuous stream of exceptions would pour forth on the console window,
ending in IDEA ceasing to run before it properly displayed itself. Using the
java.exe in the JRE that came with the JSDK and the one in the JSDK proper
resulting in IDEA halting at different points of progress.
>

As per the previous person's suggestion, I tried the JRE on the Aurora dl

page. IDEA now loads, but there is still a fair number of exceptions in the
console window and some error dialogs. Why does IDEA require a "special" JRE
package? I would really like to see IDEA work with a normal Sun JSDK/JRE
install and not require a "special" JRE package.


0

If you copied the new IDEA over a previous one, delete the ui composer plugin: it seems it is now included in the core, and as such this conflicts with the old plugin.

0

Please sign in to leave a comment.