977 pretty solid


BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Compared to other EAPs 977 is good, it's fast and responsive, debugging
works, JSP works, Tomcat works, XML doesn't have any funky issues I've
seen so far. I've worked in here for about 4 hours and I was very
productive. I've filed a few bugs, but all minor annoyances.

R
-


BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.3 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQE/tYS8+cV9vuB27SARAirnAJ4rrqpRGo9zo/knqBBm8m1a48q6nwCg3zo8
wGCJB44YDhPUpIKM1g2nw=
=qD6H
-


END PGP SIGNATURE-----

7 comments

I can't really confirm that. Single stepping in the debugger is terribly slloooowwwwww!!! I have to wait up to 5 seconds until one line of code is executed.

0

Don't you have "Suspend all threads" button in the debugger's toolbar
pressed? This build has a known bug that it gets pressed each time when you
start new debugging session. So you should uncheck it manually.

--
Valentin Kipiatkov
JetBrains, Inc
http://www.intellij.com
"Develop with pleasure!"

"Martin Fuhrer" <mf@fuhrer.com> wrote in message
news:11551717.1068881543832.JavaMail.itn@is.intellij.net...

I can't really confirm that. Single stepping in the debugger is terribly

slloooowwwwww!!! I have to wait up to 5 seconds until one line of code
is executed.


0

BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

yeah I noticed that and I check it off, hence no issues.

Valentin Kipiatkov (JetBrains) wrote:
| Don't you have "Suspend all threads" button in the debugger's toolbar
| pressed? This build has a known bug that it gets pressed each time
when you
| start new debugging session. So you should uncheck it manually.
|
-


BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.3 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQE/tjsL+cV9vuB27SARAmptAJsGmkKMFMkAfaT8Aveyk5d3Slnf5QCgxLOB
ENTn4Wr+D3NhZjOX13Ts48E=
=KgwO
-


END PGP SIGNATURE-----

0

yeah I noticed that and I check it off, hence no issues.


So is it still very slow when Suspend all threads is off?

--
Valentin Kipiatkov
JetBrains, Inc
http://www.intellij.com
"Develop with pleasure!"


"Robert S. Sfeir" <robert@codepuccino.com> wrote in message
news:bp5dud$48c$1@is.intellij.net...

---BEGIN PGP SIGNED MESSAGE---
Hash: SHA1

>

yeah I noticed that and I check it off, hence no issues.

>

Valentin Kipiatkov (JetBrains) wrote:
| Don't you have "Suspend all threads" button in the debugger's toolbar
| pressed? This build has a known bug that it gets pressed each time
when you
| start new debugging session. So you should uncheck it manually.
|
---BEGIN PGP SIGNATURE---
Version: GnuPG v1.2.3 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

>

iD8DBQE/tjsL+cV9vuB27SARAmptAJsGmkKMFMkAfaT8Aveyk5d3Slnf5QCgxLOB
ENTn4Wr+D3NhZjOX13Ts48E=
=KgwO
---END PGP SIGNATURE---

>


0

Hence = from this point on

In other words, unchecking solved the problem.

0

BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

I never said it was slow, I noticed that when debugging first kicks in
there is a slight hesitation, 5-10 seconds, then everything is OK when
stepping with suspend all threads off.

R

Valentin Kipiatkov (JetBrains) wrote:
|>yeah I noticed that and I check it off, hence no issues.
|
|
| So is it still very slow when Suspend all threads is off?
|
-


BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.3 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQE/tpIg+cV9vuB27SARAg26AKCK4PtgxvR4ldeG5MCRm3e1yXq88wCfflz3
y7SAPQvsfAvW3Sgtd6S8Nsk=
=NPcQ
-


END PGP SIGNATURE-----

0

Don't you have "Suspend all threads" button in the
debugger's toolbar pressed?


Yes, that's it. I didn't notice that this option was set 'automagically'. Now it works perfectly. Thanks.

0

Please sign in to leave a comment.