Upgrading from 6.0 to 8.0

Hi,

I've been trying for forever to get our company to upgrade our Intellij IDEA licenses. I tried the 7.0 version 9 months ago in an effort to show how much faster and better everything was but they still wouldn't cough up the money for a license. so I was forced to let the evaluation license expire and go back to version 6. Since then we've undergone some system moves and I've changed the configuration on several things. Now this week I'm being told we finally have approval and we'll be getting the upgrade license by the end of the week. I downloaded the new 8.0 version so I could install it and work out the plugin upgrades and configuration changes so I could pass it on to our other developers and users but ran into a problem. When IDEA 8 starts up it asks me if I want to copy configurations from a previous version but when I point it at the IDEA 6 directory it tells me that it's not a valid directory. Are we not able to upgrade directly from version 6 to version 8?

I think I can manage the install for the other developers here if I install 7 on their machines and then 8 but it seems like a real hassle. For me personally the settings I have in my version 7 installation are out of date and when I try to launch that version it tells me that my trial has expired and quits out. Trying to uninstall and reinstall doesn't seem to help (though I don't think I uninstalled all the files from version 7 either...)

edit: ok, just before posting this it occurred to me that maybe I could export a settings jar when running under 6.0 and then import it under 8. Thought it was worth a try. I initially had a panic because all my 6.0 settings were gone! I don't know if the idea 8 installation caused that or not. thankfully I remembered to backup before I started fiddling with the upgrades and I was able to copy the backup back in and start successfully. I did an export settings in 6.0 and then used 'import settings' from within 8.0. It seems to have worked, at least there weren't any complaints about the file from IDEA. Are we going to have to do this with everyone we upgrade from 6 to 8 or could it just be something kooky about my setup or something I did? Please let me know if there are any tips in upgrading.

Thanks,

2 comments
Comment actions Permalink

Hello Ronald,

Hi,

When IDEA 8 starts up it asks me if I want to copy
configurations from a previous version but when I point it at the IDEA
6 directory it tells me that it's not a valid directory.


I have just tried to point to directories with 5766 and 6180 builds installation
(both are IDEA 6.0). Version 8 successfully picks up them and import settings.
Are you sure you have pointed to correct path? This should be IDEA installation
directory, under which "bin", "lib", etc subdirectories are located. Can
it be corrupted?

Alexander.


0
Comment actions Permalink

I'm thinking now that I messed up when I backed up my configuration. I used drag and drop and instead of copying the files, it moved them. Thus idea errored properly because it couldn't find anything.

0

Please sign in to leave a comment.