957 (and before) with WebSphere

Has anyone had this problem before?

When I'm debugging on either a "local" (on my same box) or remote WebSphere 4.06 (Single Server version) the appserver/jvm always terminates whether or not I choose to just stop the debugging or to terminate the debugged program.

Weblogic and other app servers don't seem to exhibit this same problem, and when I try to do the same thing with Eclipse, the application continues while the debugger exits. It seems to be confined to Idea and WebSphere.

I have not tried this with other versions of the app server nor with the currently shipping version of Idea.

Has anyone experienced this problem? Unfortunately, I can not upgrade from 4.06 at this time.

Thanks for everyone's help. If others have experienced this and there are no known workarounds, I'll go ahead and post a bug.

Thanks!
-Chris

6 comments

In what mode do you connect remote debugger?

0

I'm assuming you're asking whether socket or shared memory.. I'm using socket and I start websphere with:

-Xdebug -Xnoagent -Djava.compiler=NONE -Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=7777

-Chris

0

I'll try to reproduce your problem. What JDK do you use for Websphere?

0

It's the one that comes with Websphere... It's a variant on IBM's jdk 1.3.. I'm using Websphere 4.06, but also have the problem with 4.05 and 4.01.

T hey do some JDK patching from the base JDK that ships with 4.01.

I haven't had a chance to see if this is the same with the 5.X versions, but the company that I work for is going to be on 4.6 for at least the next half year.

Thanks for your help!
-Chris

0

Have you tried going to WebSphere 5.0.2 yet? or you content with staying with 4.0.6?

0

Hmm. The problem could be that we're still on Windows for Workgroups 3.11 ;) grin Just kidding..

It's not a matter of being content, it's what we're running (we're a large regional bank), and that's what we'll be on for at least the next six months...

Any ideas with this problem?

0

Please sign in to leave a comment.