Can't get CVS tag list when right-clicking on a directory

I can't remember this ever not working for me, but now it doesn't and it's frustrating as heck.

If i right-click a file in the Project browser and select CVS -> Create Tag and then in that dialog, click the "..." button next to Tag Name (to load a list of current tags)... it works.

But if I'm on a directory (any directory), I get an error dialog instead that says "Cannot load tags: Cannot find CVSROOT for file /home/fourier/projects/projectName"

How can I fix this?

Here's what my setup is, and what I'm trying specifically to do:

All my projects are under /home/fourier/projects/
I create one 'top' folder for each project, /home/fourier/projects/projectName
Under this directory I'll CVS checkout a project and that normally results in
/home/fourier/projects/projectName/projectName/ (sources, CVS folder, etc, etc, are at this level)
Then I create an IntelliJ project on top of this, such that the *.ipr and *.iws files are at /home/fourier/projects/projectName and the *.iml file is at /home/fourier/projects/projectName/projectName

So now my code is "ready", and what I want to do is tag the entire repository with a release tag. What I'm used to doing then, is right-clicking the "projectName/projectName" folder in the Project Explorer and "create tag.... ". This is what doesn't work, and while testing, I see it doesn't work for any folder, at any level.


This is at work, and I've recently received an upgraded desktop. I thought I had transferred all files over to the new system, but perhaps I've forgotten something? A lot of other CVS operations seem to work (updates, commits, etc).

Edited by: Mike Fourier on Oct 1, 2008 2:22 PM

1 comment
Comment actions Permalink

Hello,

With Serge's help from IntelliJ support, I've figured out what's wrong. It's with how I'm structuring the project folders and where I put the IntelliJ files (or rather, where I tell IntelliJ to put them).

Normally, an IntelliJ project might look like this:


But, what I do is this:


But the problem with my setup, is that "by default IDEA uses the directory with the ipr file as the CVS root directory". Which in my project structure, is not correct. To fix that, go into File > Settings > Version Control and in the first tab, edit the Directory field to point to (in my case) /home/mfourier/projects/projectNameDir/repositoryNameDir

0

Please sign in to leave a comment.