Any way to disable the JRE version check?

I'm doing some experimenting because of a bug that appears in IDEA on my system.

I need to run build 856 on the older version of the JRE (the one that came with 833) in order to check if this bug dissappears from 856 (currently it only appears in 856 and not in 833 and the main difference between them is that the JRE was updated... this is why I want to try 856 with the old JRE in order to test if the bug is related to the new JRE).

Currently, 856 won't run because it doesn't have the right JRE version, but I need to force it to run (just for a little while) in order to see if the bug is there.

I seem to remember reading something about an option that disabled the check but I can't find it now of course.

I want to emphasize that I'm doing this purely for testing purposes and I have no gripe about IDEA bundling its own JRE. This message is not intended to start another debate about that...

Kind regards, Stefan Freyr.

p.s. the bug I'm talking about is: http://www.intellij.net/tracker/idea/viewSCR?publicId=14810

2 comments
Comment actions Permalink

Hi Stefan,

by specifying

-Didea.no.jdk.check=true

you may use a JDK of your choice. I'm running on 1.4.2_02 with nor problems.

Robert

0
Comment actions Permalink

Great! Thanks :o)

I just tried switching the JRE in build 957 over to 1.4.1 (the old jre that came with pre-856 or so builds) and added that option to idea.sh.

The short story is that I have resizing dialogs now and all is well :o)

But now for the big question:
IntelliJ team: What is it that makes you want to run JRE 1.4.2? Is it anything besides some bug fixes? Because since IDEA seems to be running fine with 1.4.1 (even better in my case due to the dialog resizing issue). So is there anything that I should expect not to work by switching over to 1.4.1?

Kind regards, Stefan Freyr.

0

Please sign in to leave a comment.