Struts Facets won't allow setting Tiles option

Hi All

I've got a project set up with three modules two of which contain a struts facet. The first module (call it "A") is configured with a web facet(?) which contains a struts facet. It's set up for 1.2.x and uses tiles. The second module (call it "B") should be configured similarly. It has the web facet(?) which also contains a struts facet. However, when I try to enable the tiles support for module B, IntelliJ pops up the progress box and then sets the focus on Module A. If I click back to Module B it's tiles check box is no longer enabled. As a result I can never turn tiles on for Module B and my struts config file is full of errors that don't exists. Can someone help me sort this out?

3 comments

Hi Jim, have you struts library in both modules' classpath? Could you attach
your iml/ipr files?


0

Hi Dmitry- the struts classes are part of a larger project library so I thought I was covered by adding the library as a dependency of the modules. While waiting for a forum response, I deleted the modules and recreated them. As part of the process I allowed IntelliJ to pull down the struts libraries for itself. Unfortunately this didn't make a difference for all my modules two out of the three now appear to work properly but one still refuses to accept the tiles struts feature setting. The behavior is still the same, I check the tiles checkbox, hit accept and the focus jumps up to the top module.

If you don't mind, I'll send you my iml files directly via email.

Thanks,

Jim

0

I'm having the same problem in 7.0.4 EAP (7878)

I check the box for "tiles", hit apply and the box unchecks itself.

But each time I do this it adds a servlet and mapping to my web.xml (for "action"), ignoring the one defined that even though the one I defined works fine. If I do the "check/apply" to the tiles setting 10 times I will get 10 servlets and mappings in web.xml. It also keeps adding a tiles plugin to my struts-config.xml.

There are no error messages.

0

Please sign in to leave a comment.