Tomcat port already is use

All of a sudden I'm having an issue starting up tomcat from idea. I get an error, 'Addres localhost:8080 is already in use'. I get the same error regardless of the port I set in server.xml. I can however start tomcat from catalina.bat. I also am not able to connect to the port in question using telnet. Does anyone have any suggestions on how to troubleshoot this problem?

Thanks

3 comments
Comment actions Permalink

Do you have any firewall software installed?

All of a sudden I'm having an issue starting up tomcat from idea. I get an error, 'Addres localhost:8080 is already in use'. I get the same error regardless of the port I set in server.xml. I can however start tomcat from catalina.bat. I also am not able to connect to the port in question using telnet. Does anyone have any suggestions on how to troubleshoot this problem?

Thanks



--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0
Comment actions Permalink

Hello Robert,

Have you changed the port for tomcat, by any chance? If so, you might be
hitting this bug (or something related):
http://www.jetbrains.net/jira/browse/IDEADEV-14530

Best,
Andrei


0
Comment actions Permalink

Hello,

we have got the same problem and it took us a while to figure out what was the real problem:

NOD32 antivirus was monitoring port 8080. (Other guys on some forums had the same problem with Kaspersky I guess...)

Idea could not figure this out, so it just give the following message: 'Addres localhost:8080 is already in use'.

The problem was fixed by removing port 8080 from the list of monitored ports from NOD32, and also removing the Idea application from the monitored application list.

Good luck ;)

0

Please sign in to leave a comment.