IDEA, symbolic links, and PROJECT_DIR

Finally figured out a problem that was driving me nuts - the solution might be useful to others out there:

I'd keep opening up my project in IDEA, and it wouldn't be able to find the modules in the project. It kept saying "Can't find $PROJECT_DIR$/foo.iml", when the file clearly existed. I tried adjusting the 'use relative' and 'use absolute' paths options, but to no avail. If I manually edited the paths in the .ipr, then things worked fine until the next time I loaded up the project file, and the same problem would occur.

Turns out the problem was that the path to the '.ipr' file had a symbolic link to a directory. The actual file was here:

/Users/ericlambrecht/Projects/foo/svn/trunk/foo.ipr

but I was loading up

/Users/ericlambrecht/foo/foo.ipr

where '/Users/ericlambrecht/foo' was a symbolic link to '/Users/ericlambrecht/Projects/foo/svn/trunk'.

Loading up the .ipr with a path with no symbolic links in it fixed everything. Hope this helps somebody else out there.

(I'm using build 7757 on OS X Leopard on a Macbook Pro)

Eric...

Edited by: Eric Lambrecht on Jun 24, 2008 12:24 AM

Please sign in to leave a comment.