Perforce integration in 6.0.5 suddenly listed unedited files as unversioned

I have a reasonably large project:
~ 40 modules
~ 3300 files of which most are .java files.
1.4 JVM
Perforce integration across entire project.

Until recently, this worked just fine. Yesterday, the VM crashed.
Such crashed have happened many times before, and I've learned to put up with the occasional inconvenience.

This time, when IDEA started up again, all unopened source controlled files suddenly became listed as "Unversioned Files" in the "Changes" panel. Any 'automatic' check-outs -- for example from a method rename refactoring -- only allows files to be edited by clearing ReadOnly "using file system". Earlier, such operations allowed ReadOnly to be cleared using Perforce.

If I open one of these "unversioned" files directly, and use "Version Control" --> "Perforce" --> "Edit", the file is opened for edit, and suddenly appears in one of the changelists in the Changes panel. Reverting the file returns it to the unversioned section.

I've tried restarting, rebooting, opening all files for edit and reverting using perforce directly. I also looked through the .iws file, but I've not found the problem.

Has anyone else dealt with this problem? Any ideas?

Comment actions Permalink

Just an update -- I am working around this problem in 7.0.x by specifying the P4 username, password etc in the IDEA configuration (rather than using (the preferred) P4CONFIG model.

So this became less of a productivity issue, and more of a security & usability issue.

Comment actions Permalink

Please provide more details about the project so that it will be easy to give feed back from our side.



Christian Drug Rehab]]>


Please sign in to leave a comment.