which jdk for idea-7757

I just upgraded my Linux OS (Mandriva 2008.1) but can't remember which Java SDK I need.

I tried jdk-6u5-linux-i586 just out of curiosity, but couldn't get around its compile errors, so I tried jdk-1_5_0_15-linux-i586 but get startup errors of "Exception in thread "main" java.lang.UnsupportedClassVersionError: Bad version number in .class file"

Could someone please indicate which jdk I need.

2 comments
Comment actions Permalink

What compile errors?

0
Comment actions Permalink

I'm beginning to think that the compile errors were caused by trying to move to GWT 1.5. I also have IDE display issues, but I think that may be caused by my using Compiz-Fusion. As long as I don't use Java 1.5 features it seems GWT 1.4.x will work.

So, it seems not to be an IntelliJ issue.

0

Please sign in to leave a comment.