Format code and Ubuntu

Hi.
I'm running IntelliJ 7.0.2 on Ubuntu 7.10
When trying to format my code with CTRL + ALT + L , Ubuntu locks the system (it seems that this buttons combination is reserved for Ubuntu).
I tried to format the code via the main menu, but I got an empty dialog box.
Any ideas?

3 comments

"CTRL + ALT + L" is Ubuntu Lock screen shortcut key so its not working for this.

Try ,

Right click on the folder you like to reformat, choose "Reformat code" from the menu or click "Code" button on navigation bar in top, choose "Reformat code"

Thank you

1

Hello Hussein,

When trying to format my code with CTRL + ALT + L , Ubuntu locks the
system (it seems that this buttons combination is reserved for
Ubuntu).


You could remap IDEA action to a free shortcut. I tried AltShiftL, seems
to be working.

I tried to format the code via the main menu, but I got an empty
dialog box.


Hm, I do not see this effect. Ubuntu 6.06, GNOME and KDE.

Alexander.


0

1. You can either remap your keyboard settings in IntelliJ or change them in Ubuntu. To change the Lock Screen keyboard shortcut, go to System/Preferences/Keyboard Shortcuts and edit the "Lock Screen" settings.

2. You probably need to turn off additional special effects in the UI. Go to System/Preferences/Appearance/Visual Effects and choose "None". This solved my empty dialog problems.

0

Please sign in to leave a comment.