Setting a browser in IDE Settings (Mac os x)

Hi!

When I try to set the browser to Safari in the IDE settings, well... I can't select Safari since Intellij thinks that it is a folder...

I have to go into the package and select some Safari there... but that is not ideal since this will fool Os X into starting a whole new Safari when I click e.g. Online Documentation in the Help menu, even if I already have Safari running.

Any solutions?

Gauti

3 comments
Comment actions Permalink

Any solutions?


Set the path by hand in config->options->ide.general.xml?


0
Comment actions Permalink

This has been talked about quite a lot recently. Set the path to the browser as '/usr/bin/open' this will honour your default browser choice. Try searching the forum for more details.

0
Comment actions Permalink

Carlos Costa e Silva wrote:

>>Any solutions?


Set the path by hand in config->options->ide.general.xml?


That is a hack--not a solution. The solution is to allow
IDEA to choose a directory if it ends in ".app" and the
Platform is OS X.

Hacks involve nad editing files to a commercial application.
Solutions involve making the commercial application function
as expected.

0

Please sign in to leave a comment.