Ant itegration lose variables on #896 !!!?!!!

Hi!

I had an #896 installation, when I try to lunch ant I get errors about symbols not defined.

Those symbols shouold be read with: ]]>
As it has been since I use Idea.

This didn't happen with #873 or Idea 3.0.4 using the same build.xml!

Is there any lack of ant variable support or something like it? Thanks!

7 comments
Comment actions Permalink

Jose Tomas wrote:

I had an #896 installation, when I try to lunch ant I get errors about symbols not defined.

Those symbols shouold be read with: <property file="setup/common.properties"/>
As it has been since I use Idea.

This didn't happen with #873 or Idea 3.0.4 using the same build.xml!

Is there any lack of ant variable support or something like it? Thanks!


The problem may be that the current working directory is different for
some reason. It is generally better to use a fully qualified path to
files and directories to avoid this class of error. For example:

<property file="$/setup/common.properties"/>

Ciao,
Gordon

--
Gordon Tyler (Software Developer)
Quest Software <http://java.quest.com/>
260 King Street East, Toronto, Ontario M5A 4L5, Canada
Voice: 416-643-4846 | Fax: 416-594-1919

0
Comment actions Permalink

For build #876 works also well.

The fallow builds doesn't.

Using $ as sugested doesn't work in the #build > #876.
Can it be a bug like ant integration is not reading well the line ]]> ?

For now I'm using #876.

Tnx!

0
Comment actions Permalink

Jose Tomas wrote:

Can it be a bug like ant integration is not reading well the line <project name="esegur" default="all" basedir="."> ?


No, that seems to be working okay...

When you said, "...I get errors about symbols not defined.", do you mean
the variables are red in the IDEA editor? If that's the case, that's a
known bug: http://www.intellij.net/tracker/idea/viewSCR?publicId=13169

I thought you were referring to errors when you run Ant.

Ciao,
Gordon

--
Gordon Tyler (Software Developer)
Quest Software <http://java.quest.com/>
260 King Street East, Toronto, Ontario M5A 4L5, Canada
Voice: 416-643-4846 | Fax: 416-594-1919

0
Comment actions Permalink

Yes, the variables state is red, but also the ant doesn't run stating that symbol, which variable is red, isn't defined.

Tnx

0
Comment actions Permalink

Ok!
I think the answer to the problem is that some folders pointed by the ant properties in config files (.xml & .properties) are in the exclude folders tree.

Why am I saying this? It's because I removed for other reasons some folders from exclude folders tree, in the project properties. At that moment lots of ant properties stated a diferent color, as being correct properties.

From my point of view the exclude folders tree should not be mandatory over the ant configuration. I think the exclude folders tree feature should only be for visual effect, not applicational.

Thanks!

0
Comment actions Permalink

Hey... I forgot one thing!

I need to have the following line:
It seems the first line at build.xml: ]]>
doesn't have the correct read by setting basedir property.

I read the bug text you refered, but I didn't find a correct matching for this problem.

Thanks!

0
Comment actions Permalink

Jose Tomas wrote:

I need to have the following line:
<property name="basedir" value="."/>

It seems the first line at build.xml:
<project name="esegur" default="all" basedir=".">
doesn't have the correct read by setting basedir property.


That's what that bug report was about. "Builtin" properties like basedir
are not recognized in the editor. But if you define it using a property
tag, then it will recognize it. It's a bug.

BTW, basedir="." is redundant. The default value of basedir is the
directory in which the build.xml resides.

Ciao,
Gordon

--
Gordon Tyler (Software Developer)
Quest Software <http://java.quest.com/>
260 King Street East, Toronto, Ontario M5A 4L5, Canada
Voice: 416-643-4846 | Fax: 416-594-1919

0

Please sign in to leave a comment.