load fs changes question

using idea on a mac

I svn up in a terminal outside of the mac
run synchronize on the directories I am working with
often I'll go to edit a file that isn't in an editor already, edit it and go to save it and then get a popup asking to load the fs changes or display a diff...

is there any way I can just force idea to always make sure its using the latest version from the disk when I have it open a file? this behavior just seems counterintuitive to me. :/

9 comments

Hello Jesse,

using idea on a mac

I svn up in a terminal outside of the mac

run synchronize on the directories I am working with

often I'll go to edit a file that isn't in an editor already, edit it
and go to save it and then get a popup asking to load the fs changes
or display a diff...

is there any way I can just force idea to always make sure its using
the latest version from the disk when I have it open a file? this
behavior just seems counterintuitive to me. :/


Do you have "Synchronize files on frame activation" enabled in the settings?

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

fwiw, I remember having this problem in 6, but I was having so many performance problems it took a bit of a backburner...

now its back and annoying me with a vengeance again

I suspect it might go away if I were to consistency interact with svn via idea, but I have never liked using scm tooling in IDE's

0

you really should give a chance to IDEA's scm integration, from my point of view it's one of the very good features of IDEA

0

I use it sometimes, but I shouldn't have to be forced to use it for every operation imo

0

would it help if I specify that this behavior is only seen on macosx....I never see it on linux and I operate the same way in both environments

0

I'm having the same issues on Mac OSX with 7.0.2. I just upgraded from 6.0.6 where the local and automatic fs synchronization worked fine. I'm a bit disappointed to have taken a step backwards in this regard.

-Clayton

0

The automatic file synchronization is now working on my machine. I opened up the contents of the 7.0.2 app and renamed the bin/fslogger file so it wouldn't load and it seems to be running fine now.

Note that this is apparently a known issue on Leopard but I was seeing this in 10.4.11

0

hm, I'll give that a whirl..

yes, I was seeing this over a year...year and a half ago on a powerbook so its been lingering around for a while.

thanks!

0

Please sign in to leave a comment.