IDEA is not discovering the source.

Hi.

Has anybody else had this problem?

I have a project that is using Batik (Apaches SVG implementation) libraries. I've set everything up in the libraries (see attached image "batik-library.png"). The class files are in many different jar files but the source was put into one big jar file.

Now, my problem is that no matter how hard I try, I cannot get the QuickJavaDoc to work, nor do I get any parameter names in my code completion and when I choose Go To -> Declaration or Go To -> Implementation, I only get the class file opened!

I'm baffled here and until I know why this is happening, I'm not going to file a bug report (especially since this seems to be a unique case... all my other projects are able to give me Quick JavaDoc although I sometimes have the problem of Go To -> Whatever does give me the .class file instead of the .java file (but I think that's a known bug).

Does anybody else have this problem? Anybody have a solution to it?



Attachment(s):
batik-library.png
3 comments
Comment actions Permalink

I ran into this problem just yesterday. But its not for all sources. I
have some libraries with sources that idea can find, and others that it
cannot. I have not yet been able to determine any pattern.


Stefan Freyr Stefansson wrote:

Hi.

Has anybody else had this problem?

I have a project that is using Batik (Apaches SVG implementation) libraries. I've set everything up in the libraries (see attached image "batik-library.png"). The class files are in many different jar files but the source was put into one big jar file.

Now, my problem is that no matter how hard I try, I cannot get the QuickJavaDoc to work, nor do I get any parameter names in my code completion and when I choose Go To -> Declaration or Go To -> Implementation, I only get the class file opened!

I'm baffled here and until I know why this is happening, I'm not going to file a bug report (especially since this seems to be a unique case... all my other projects are able to give me Quick JavaDoc although I sometimes have the problem of Go To -> Whatever does give me the .class file instead of the .java file (but I think that's a known bug).

Does anybody else have this problem? Anybody have a solution to it?


0
Comment actions Permalink

Does it have anything to do with the size of the src jar file? How large is your source file?

This is the only time I've had this problem and it just so happens that I'm using a single, rather large, source file (2.1 Mb compressed).

How about you?

0
Comment actions Permalink

I have a project that is using Batik (Apaches SVG implementation)

libraries. I've set everything up in the libraries (see attached image
"batik-library.png"). The class files are in many different jar files but
the source was put into one big jar file.

But I see no attached image! Also I think it's easier to process this issue
if it would be in the Tracker - please post it there.

--
Valentin Kipiatkov
JetBrains, Inc
http://www.intellij.com
"Develop with pleasure!"


"Stefan Freyr Stefansson" <stefanf@althingi.is> wrote in message
news:15363225.1060177634166.JavaMail.itn@is.intellij.net...

Hi.

>

Has anybody else had this problem?

>

I have a project that is using Batik (Apaches SVG implementation)

libraries. I've set everything up in the libraries (see attached image
"batik-library.png"). The class files are in many different jar files but
the source was put into one big jar file.
>

Now, my problem is that no matter how hard I try, I cannot get the

QuickJavaDoc to work, nor do I get any parameter names in my code completion
and when I choose Go To -> Declaration or Go To -> Implementation, I only
get the class file opened!
>

I'm baffled here and until I know why this is happening, I'm not going to

file a bug report (especially since this seems to be a unique case... all my
other projects are able to give me Quick JavaDoc although I sometimes have
the problem of Go To -> Whatever does give me the .class file instead of the
.java file (but I think that's a known bug).
>

Does anybody else have this problem? Anybody have a solution to it?




0

Please sign in to leave a comment.