How to disable splash screen


I would like to disable the IntelliJ IDEA startup splash screen. Please let me know how this can be done.



I use Toolbox, and my solution was:

  1. Select IntelliJ Settings
  2. Click on "Install location" - "Show"
  3. A file explorer will open. Navigate into the 'bin' folder;
  4. Edit file, replacing the last 'com.intellij.idea.Main' on file for 'com.intellij.idea.Main nosplash'

That's it. I hope it helps...


Thomas Popp Help | Edit Custom VM Options, add -Dnosplash=true. Start the IDE via Toolbox. Verified and working fine.


Hello hloeblich,

I would like to disable the IntelliJ IDEA startup splash screen.
Please let me know how this can be done.

Add "nosplash" to the command line parameters.

Dmitry Jemerov
Development Lead
JetBrains, Inc.
"Develop with Pleasure!"


Hmm, I just tried this but it does not seem to have any effect. I am running IDEA 6197 on Linux, and I invoke it with
Is it supported in this version?

I tried the following: nosplash -nosplash --nosplash "nosplash"


Maybe your (older) version of IDEA doesn't support it.

7590 (7.0.2) supports the following: nosplash



This still doesn't work (Ubuntu 16.04). I tried " nosplash", but IDEA still shows useless splashscreen and steals focus from my email reader 3+ times - crazy! If you cannot fix it and/or make an option in IDE itself to disable it, can you at least make this useless window _tiny_ ?

Also, why JetBrains Toolbox doesn't provide such feature? It's a launcher after all, can it know about JetBrain's software a little? You can show splashscreen + progress bar _inside_ the toolbox and **allow to close this screen with the close-window button**.


Please follow the related issue on YouTrack: and feel free to share suggestions in comments.


I am using MacOs. How can I hide the splash screen?


With the Toolbox windows I tried everything without success. 

Starting IDEA from command line with “nosplash” or “-Dsplash=false” works just fine but the Toolbox ignores everything:

  • adding nosplash to bin/idea.bat as suggested above
  • adding “-Dsplash=false” to the VM options that are linked right in the Toolbox settings
  • adding “nosplash” or “-Dsplash=false” to the shell script refered to right in the Toolbox settings.

Something is severely broken with the Toolbox.

This splash screen doesn't just steal focus in my case but stays in the foreground the whole time until IDEA has started, up to 10 seconds, which is really annoying.


Thank you, it worked.


Please sign in to leave a comment.