873 and 876 constantly using CPU

Last two builds constantly using CPU when IDE in the idle state it jumps from 25% to 40% and then 100% cyclically.

0
16 comments

I've seen this problem since last 30 builds very rarely and still cannot
catch what causes it. Restart completely helps.

--

Best regards,
Maxim Shafirov
JetBrains, Inc / IntelliJ Software
http://www.intellij.com
"Develop with pleasure!"


"Vladimir Goncharov" <vladimir.goncharov@citigroup.com> wrote in message
news:16975711.1059589683315.JavaMail.javamailuser@localhost...

Last two builds constantly using CPU when IDE in the idle state it jumps

from 25% to 40% and then 100% cyclically.


0

No it doesn't, I think IDE is trying to parse something in the background, trying and trying like energizer rabbit. Actually it happens more when some file is open with the incorrect syntax i.e. with the red mark in the upper right corner.

0

Not exactly. At least in the thread dump there's nothing suspicious or even
sign that IDEA doing any activity. Seems like some JVM internal stuff.

--

Best regards,
Maxim Shafirov
JetBrains, Inc / IntelliJ Software
http://www.intellij.com
"Develop with pleasure!"


"Vladimir Goncharov" <vladimir.goncharov@citigroup.com> wrote in message
news:20399973.1059599258827.JavaMail.javamailuser@localhost...

No it doesn't, I think IDE is trying to parse something in the background,

trying and trying like energizer rabbit. Actually it happens more when some
file is open with the incorrect syntax i.e. with the red mark in the upper
right corner.


0

But can you see jumps in the windows Task Manager? at leats I can, close all the files then open one by one and you'll see that jumping never ends.

0

But can you see jumps in the windows Task Manager?

Exactly. And idea threads are keeping calm this time.

--

Best regards,
Maxim Shafirov
JetBrains, Inc / IntelliJ Software
http://www.intellij.com
"Develop with pleasure!"


"Vladimir Goncharov" <vladimir.goncharov@citigroup.com> wrote in message
news:24682182.1059707669227.JavaMail.javamailuser@localhost...

But can you see jumps in the windows Task Manager? at leats I can, close

all the files then open one by one and you'll see that jumping never ends.


0

BTW, can you stable reproduce this?

--

Best regards,
Maxim Shafirov
JetBrains, Inc / IntelliJ Software
http://www.intellij.com
"Develop with pleasure!"


"Vladimir Goncharov" <vladimir.goncharov@citigroup.com> wrote in message
news:24682182.1059707669227.JavaMail.javamailuser@localhost...

But can you see jumps in the windows Task Manager? at leats I can, close

all the files then open one by one and you'll see that jumping never ends.


0

Yeas, unfortunately it happens all the time. More errors on the page especially non java files such as xml ant scripts or JSPs more often it happens. In my understanding sparks are possible when file just been parsed and it should go away even if there are error on the page, it shouldn’t execute this constantly isn’t it?

0

Am I the only person who is troubled by this issue?

0


Nope, I get it as well. Dumping all of my caches, removing all plugins, and deleting project files didn't help, either.

0

Do you guys opening and closing projects much?
We've found one issue that may cause periodic 100% CPU activity on closed
project.

--

Best regards,
Maxim Shafirov
JetBrains, Inc / IntelliJ Software
http://www.intellij.com
"Develop with pleasure!"


"Dave Griffith" <dave.griffith@cnn.com> wrote in message
news:25615485.1060045570017.JavaMail.javamailuser@localhost...
>

Nope, I get it as well. Dumping all of my caches, removing all plugins,

and deleting project files didn't help, either.
>


0


Nope, it pretty much just happens whenever a file is set to be reported as having errors.

--Dave Griffith

0

I've got something similar but it seams to happen only when I have a jsp
file opened. Parsing the jsp (validate it) seems to be very CPU consuming.

My jsp's are full of special tags (Struts and home made tags). IntelliJ is
unable to recognize them. And I can't use the "Web Application Support"
because we are using Tomcat 3 on a remote server, etc, etc...



Would it be wonderful if Intellij can recognize by itself the taglibs? Even
better through the Resource list?



Thierry Leveque


"Vladimir Goncharov" <vladimir.goncharov@citigroup.com> wrote in message
news:5165943.1060023252725.JavaMail.javamailuser@localhost...

Am I the only person who is troubled by this issue?



0

ThierryLeveque wrote:

Would it be wonderful if Intellij can recognize by itself the taglibs? Even
better through the Resource list?


But it can!

I don't know if the bug is fixed but it used to be so that IDEA only
understood taglibs with the latest DOCTYPE (mostly a matter of changing
DOCTYPE and adding some hyphens if you have an older format). Maybe
that's the problem for you.

/Daniel

0

This bug is fixed. Now the only limitation on IDEA is that it isn't able to resolve "symbolic" URI's (i.e, URI's defined in the web.xml file).

0

If you need something done, do it yourself :)

The reparse error attribute in the IDE Settings – Errors was set to 0, my understanding was that 0 means don’t reparse at all, and apparently I was wrong.

0

Well I'm very curious to know how you are able to do that.

On my side, whatever I put in the URI (in the taglib declaration) I have a
"Cannot resolve tag library".

I tried a full path, a relative path, a url, a resource name (and add the
resource in the resource list with the correct reference to the file), etc
etc..

Originally, my taglib definition was in an included file, but I moved it in
the main jsp.

<%@ taglib uri="struts-html.tld" prefix="html" %>


Thierry

"Daniel Bratell" <daniel.bratell@idainfront.se> wrote in message
news:bgq22r$m11$1@is.intellij.net...

ThierryLeveque wrote:

Would it be wonderful if Intellij can recognize by itself the taglibs?

Even

better through the Resource list?

>

But it can!

>

I don't know if the bug is fixed but it used to be so that IDEA only
understood taglibs with the latest DOCTYPE (mostly a matter of changing
DOCTYPE and adding some hyphens if you have an older format). Maybe
that's the problem for you.

>

/Daniel

>


0

Please sign in to leave a comment.