cvs using plink can't load items

When using CVS via plink (Putty) in 818, I get an error message when selecting my cvsroot in the Tools | Check out project option (see attached).

My connection tests ok, and my file colors seem to change accordingly, but all other CVS operations fail too.

Am I doing something dumb here (does anyone have it working ok), or should I raise a bug?

Cheers,

Marty Andrews



Attachment(s):
cvsload.gif
6 comments
Comment actions Permalink

Hum works for me. Did you have a private key with a password? If so are
you using the Putty Agent to store that key?

It also helped me to clear out all preferences and start with a clean
project when I had issues with CVS.

R
"Martin Andrews" <mandrews@thoughtworks.com> wrote in message
news:19821108.1054624779416.JavaMail.jrun@is.intellij.net...

When using CVS via plink (Putty) in 818, I get an error message when

selecting my cvsroot in the Tools | Check out project option (see attached).
>

My connection tests ok, and my file colors seem to change accordingly, but

all other CVS operations fail too.
>

Am I doing something dumb here (does anyone have it working ok), or should

I raise a bug?
>

Cheers,

>

Marty Andrews



0
Comment actions Permalink

Hum works for me. Did you have a private key with a
password?


Yep

If so are you using the Putty Agent to store that key?


Yep

It also helped me to clear out all preferences and
start with a clean project when I had issues with CVS.


Yes - I've done this too.

Still no joy though. When I turn the Putty Agent off, I get a slightly different error:
Cannot load items (Unhandled response: Passphrase.)

...so I must be getting through, just the response is not working properly

Marty Andrews

0
Comment actions Permalink

Can you connect to the cvs server using putty?

--
Best regards,
Olesya Smirnova
JetBrains, Inc / IntelliJ Software
http://www.intellij.com
"Develop with pleasure!"


"Martin Andrews" <mandrews@thoughtworks.com> wrote in message
news:12830383.1054681566364.JavaMail.jrun@is.intellij.net...
>

Hum works for me. Did you have a private key with a
password?

>

Yep

>

If so are you using the Putty Agent to store that key?

>

Yep

>

It also helped me to clear out all preferences and
start with a clean project when I had issues with CVS.

>

Yes - I've done this too.

>

Still no joy though. When I turn the Putty Agent off, I get a slightly

different error:

Cannot load items (Unhandled response: Passphrase.)

>

..so I must be getting through, just the response is not working properly

>

Marty Andrews

>


0
Comment actions Permalink

Yep - no problems. I currently use cvs on the command line, and have also connected through eclipse. In both cases they go through putty.

Can you connect to the cvs server using putty?

0
Comment actions Permalink

I am experiencing the same issue and have a similar putty/plink configuration. Did a clean install etc.. and cannot get the CVS intergration to work (same error message that Martin has posted).

0
Comment actions Permalink

I have finally been able to get this to work. In my situation all I needed to do was update the version of plink and pageant I was using. I am now on 0.53b of pageant. Was on 0.50.

0

Please sign in to leave a comment.