Changes Local View: Error Updating Changes

Hi I just noticed an error in at the bottom of the changes panel:

Error updating changes: svn: This client is too old to work with the working copy 'c:\data\projects\xxx\src\doc'; please get a newer Subversion client

This error never appeared while using the svn client in IDEA 6. Our svn hasn't been upgraded so I don't know why the latest IDEA 7 svn client would be too old.

Can anyone explain this error?

1 comment

Hello Jim,

Hi I just noticed an error in at the bottom of the changes panel:

Error updating changes: svn: This client is too old to work with the
working copy 'c:\data\projects\xxx\src\doc'; please get a newer
Subversion client

This error never appeared while using the svn client in IDEA 6. Our
svn hasn't been upgraded so I don't know why the latest IDEA 7 svn
client would be too old.

Can anyone explain this error?


The text of the error message is misleading. The problem actually happens
when the background changes update occurs while another SVN operation (update
or commit) is running. You can simply press Refresh in the Changes view to
get rid of the error.

This problem is also described by the JIRA issue http://www.jetbrains.net/jira/browse/IDEADEV-21776

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0

Please sign in to leave a comment.