No JPA Support?

I have not been able to locate anyway to create a EJB 3.0 Entity in your latest trial. Is this not supported? That seems to be very odd.

In addition it looks like your Hibernate support is broken. I selected Hibernate as a module for my project and I ended up with it unable to download files.

It looks like your latest version is lacking behind NB for JEE5 support which is a disappointment since I was hoping to make use of your Groovy support but full JEE5 support is of much more importance. I also would like to try out BEA Kodo for the JPA but it looks like you only support Hibernate and for that not even the JPA?

8 comments

Hi,

Did you add the JPA facet to your module?

With that, I could create an entity class from a given DB schema, and had all the editor supprt which is advertised. However, I did not find any possibility from within the IDE to create a DDL from the entity (which is disappointing).

It seems that you are another victim of the unsufficient documentation provided with the release. ;)

Kind regards

Thomas Gülden
Munich, Germany

0

Ah I see now. I was under the expectation that I would be able to create a JPA Entity as the other options are under new. It is weird that I manually need to create the class instead of having it automated.

0

Another odd thing is why does it not allow me to add external individual jar files to the project? It insists on me providing a directory containing jars? The interface to IntelliJ is not very intuitive compared to others. Many options that should be very visible appear to be embedded deeply in layers of menu options.

I'm a first time user and being so my first impressions are a bit disappointing.

0

Use "Attach Classes..." for that. You can select one or more jar files (or also directories containing class files).

0

Samuel,

You are a very good example of the difficulties new user do have with IntelliJ, despite of its much better usability, once you have stepped over the initial hurdles.

I believe this could be solved, if JetBrains decides to improve the docs / user guide / online help significantly, as I said elsewhere.

But be sure, once you've overcome the first problems, you won't go back to another IDE. (In Eclipse, it isn't possible, to print code with line numbering, basic stuff even!)

Kind regards

Thomas

Thomas Gülden
Munich, Germany

0

In addition it looks like your Hibernate support is
broken. I selected Hibernate as a module for my
project and I ended up with it unable to download
files.


Hi Samuel,

If for some reasons you cannot download the Hibernate files in IDEA, you can pick them from a local folder. Hope that help.

T.

0

Sorry, but how can one pick them from a local folder? I'm also a newbie to IDEA...

Thanks.
Chau

0

+ If you create a new project, at the last step, check the Hibernate check box and you will see Change button. The dialog has an option to pick libraries from a local folder.
+ If you want to add Hibernate facet to an existing project, select the module, add Hibernate facet, select the Hibernate facet item and you will see a small Fix button at the down right corner.

For other facets, they should work the same way.

Hope that help.

T.

0

Please sign in to leave a comment.