Name space for JSF not resolving

What's the trick to get IDEA to resolve JSF name spaces so that they and their associated tags validate/aren't red?

For example my file has:

xmlns:h="http://java.sun.com/jsf/html"
xmlns:f="http://java.sun.com/jsf/core"

Which show up as red. You also can't fetch the external resource because there isn't anything at that URL. All associated JSF tags in my file are red as well.

I am using IDEA 7 build 6833.

TIA

4 comments
Comment actions Permalink

Update:

I downloaded the Milestone 2 build and created a new web application project from scratch. I selected JSF 1.2 and let IDEA set up the lib directory which included jsf-api.jar, jsf-impl.jar, and jstl.jar. Now in an xhtml file the JSF core name space resolves, however, the JSF html namespace continues to show up as unresolved (red). Is this broken, or am I broken?

In addition to this I am unable to get the SEAM taglib -

xmlns:s="http://jboss.com/products/seam/taglib"

to resolve, even though my web app module has the jboss-seam-ui.jar in its class path and this jar contains the s.taglib.xml and s.tld files.

Getting IDEA to resolve NS has not been much of a 'pleasure' for me ;)

TIA

0
Comment actions Permalink

This is a bit maddening. The html_basic.tld file which includes the tag definitions for the

xmlns:h="http://java.sun.com/jsf/html"

is included in the jsf-impl.jar which is downloaded by IDEA when you create a web app project. Why then is it still not resolving when included in an xhtml file like so:

]]>

For the record the seam taglib will not resolve either even though I have the jar that includes the tag lib included in my project (and class file it contains are resolved - references to servlet filters in the web.xml file for example resolve).

The only way I have been able to get the SEAM tags to resolve is to manually extract the xml file from the jar and include it in the IDEA resource preferences. This is less then 'pleasurable'. Is this the only way to fix this? Anyone?

0
Comment actions Permalink

What filetype do you have assigned to .xhtml?

0
Comment actions Permalink

I resolved this by associating *.xhtml with JSPX files, adding the resources to the settings (take the URL that you see at the top of the page, like http://jboss.com/products/seam/taglib, go to File/Settings/IDE Settings/Resources/Configure External Resources, add one resource entry per URI(L), put http://jboss.com/products/seam/taglib as the URI (for example), and then find where the dtd file is for that URI (usually in a jar), like C:\dev\workspace\jboss-seam-2.0.0.GA\lib\jboss-seam-ui.jar!\META-INF\s.tld),
then, go actually add the jar file as a File/Settings/Project Setting/module]]>/dependencies/single module dependency)... do that for all your URIs and you should be good to go. So resolving the red is just a matter of entering the resources. Making control-space work with the tags in a matter of putting the library dependencies into the project.

0

Please sign in to leave a comment.