spurious "Cannot resolve symbol" errors in 7.0 editor

I posted a question about this before, but upgrading from 7.0R6 to 7.0 seemed to fix it. But, it turns out there were still a few spurious red lines that won't go away.

I haven't seen a recurrence of the superfluous red lines in the editor due to jar updates, but right now I have an error in the editor where it says "Cannot resolve symbol" for a class that exists in the same package and same directory in the same project.

In particular, the class com.ign.pxed.editInstance.client.EditInstance is unable to see (in the editor) the class com.ign.pxed.editInstance.client.EditSelfContainedInstance

It builds and runs fine. I tried deleting the system directory, the target directories, and doing a full rebuild. Nothing has fixed the issue. I haven't tried recreating the project files yet.

What should I delete or rebuild to make this go away?

2 comments

Here are additional details:

I found that I could temporarily fix the issue by renaming the class (using alt-shift-r and then manually changing the name manually for the ones that the refactor doesn't find due to the symbol not found error) to another class name. Specifically, I renamed EditSelfContainedInstance to EditSelfContainedInstance2 and the symbol not found error went away for that class.

But, it came back later on. I'm up to EditSelfContainedInstance5. That worked fine for a couple of days and now it's red lined again. I have not yet figured out what causes it to red line. I just renamed it to EditSelfContainedInstance again and the error went away, so apparently it's not necessary to avoid previous names when renaming.

0

Maybe setting the 'clear output directory on rebuild' in the project - compiler settings will help. (and then use the rebuild task ...)

0

Please sign in to leave a comment.