Why package not shown ?

I running Intellij 6, and one of the usability problem I have in intellij is this:
Why is the package create using New -> Package context menu not show on the project list ?
Does it really make sense not to show Package that you explicitly created or did I miss some settings somewhere?

If it is settings, it is obvious that package if no class must be shown, otherwise what the use of New Package, I may as well create from Windows Explorer ?

Please do fix this usability flaw.

6 comments
Comment actions Permalink

Hello matthewarena,

I running Intellij 6, and one of the usability problem I have in
intellij is this:

Why is the package create using New -> Package context menu not show
on the project list ?

Does it really make sense not to show Package that you explicitly
created or did I miss some settings somewhere?

If it is settings, it is obvious that package if no class must be
shown, otherwise what the use of New Package, I may as well create
from Windows Explorer ?


The most likely reason why you're not seeing the package is that the name
of the package you're creating matches a name specified as ignored in Settings
| General | Ignore files and folders. Is that the case?

--
Dmitry Jemerov
Software Developer
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Thank for the answer it solve my problem when I clear the textfield.

I have just check that option, it has the following content

CVS;SCCS;RCS;rcs;.DS_Store;.svn;.sbas;.IJI.*;vssver.scc;vssver2.scc;

in Ignore Files and Folders textfield.

Why not simply display empty package as default rather than hide it since we expect it to show package ? Otherwise, Intellij will just confuse beginner and think that it is a bug. I mean one use Create Package, and definitely expect the package to appear, right ?

To show the created empty package will be > 90% expected it , so why not set as default ??

hope Intellij do change this settings to make it more predictable...
thx...

0
Comment actions Permalink

Hello matthewarena,

Thank for the answer it solve my problem when I clear the textfield.


So what was actually the name of the package you tried to create?

I have just check that option, it has the following content

CVS;SCCS;RCS;rcs;.DS_Store;.svn;.sbas;.IJI.*;vssver.scc;vssver2.scc;

in Ignore Files and Folders textfield.

Why not simply display empty package as default rather than hide it
since we expect it to show package ? Otherwise, Intellij will just
confuse beginner and think that it is a bug. I mean one use Create
Package, and definitely expect the package to appear, right ?

To show the created empty package will be > 90% expected it , so why
not set as default ??

hope Intellij do change this settings to make it more predictable...
thx...


The only thing that can be improved is that IntelliJ IDEA could give a warning
like "the package name you're trying to create matches an ignored file name".
The package with such a name cannot be shown all the time because the "ignore"
feature is there for a reason, so if we did as you suggest, the package would
be shown immediately after creation and then disappear at some unknown point
in the future. Which is obviously much worse than the current behavior.

--
Dmitry Jemerov
Software Developer
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

That will be a good idea to show warning.
In fact, I am creating few packages called
ui
component
data

and these do not appear at all. I have to manually add a dummy files to those package directory before I can use it in Intellij. That is before I know of your solution.
I'm sure many people will have ignore this options.

Putting a warning message and then directing people of the option to use to change setting will be good idea.

It's good to know it is not bug in Intellij.
thk

0
Comment actions Permalink

Why would you ever create a package that matches a directory name listed in the default list of ignored directories anyway? All of them appear to be well known directories for various tools (like .svn for subversion and CVS for cvs)

0
Comment actions Permalink

In fact i did not, I just create package that doesn't conflict with version control system, but yet those package are not shown until I start putting file in it outside Intellij. Could this be a bug in intellij then ?

0

Please sign in to leave a comment.